UE4/4.23 system font bug?

After I updated to 4.23, I opened the project text and it became like this. What should I do?


Same problem!

Same issue with system font after project upgrade

This is fallback glyths to inform you that characters are missing in font from that character range. So check font assets, reimport them, try to reconfigure them.

Even on native engine fonts, this problem is present.

Upd: I tried Noto font that cover Chinese and Japanese, but it’s not work…

4.22,No problem,4.23~WHY?

I have same problem :confused:

Then raport a bug Report a Bug - Unreal Engine you should get email reponce form it whatever it is valid bug or not, if not they should give you solution

There also possibility the problem is in encoding, read about it here Character Encoding in Unreal Engine | Unreal Engine 5.1 Documentation

“There also possibility the problem is in encoding, read about it here …”
Is very strange why in 4.22 is working & not on 4.23 ? I read you link but i don’t understand how to apply


open editor cmd and type



UI Bug Fix: Dragging a widget from a
non-canvas parent to a canvas in the
UI editor no longer causes the widget
to be offset. New: Made several
improvements to game controller
handling in UI code: Made a focus
change callback to FNavigationConfig
that can be used to override focus
changes or play a game-specific
effect. Added NavigationAction enum
and functions to navigation config to
replace hardcoded keys like
Virtual_Accept. This can be overridden
by a game to handle game-specific
remapping. Fixed SSlider to use
navigation instead of key input, which
fixes deadzone handling and allows
remapping. Added some functions to
KismetInputLibrary to query
navigation; this is useful for UMG
widgets that handle input themselves.
Deprecated: Legacy localized fonts are
now disabled by default. These have
been “soft” deprecated since 2014,
were formally deprecated (emitting a
warning if used) in 4.22, and will be
removed in 4.24. They can be
temporarily enabled again by setting
to 1. You should instead ensure that
your font assets are set-up correctly
by using this overview.

I had the same issue with my fonts, Tried this fix and it worked for me. all special characters like “@” returned. Thank you.