Download

UE4 4.21 - Landscape Grass Type not rendering

Hello !
I am trying to use Landscape Grass Type for a Pavlov : VR mod, but it won’t render.
Does this bug look familiar to someone? Any clues for a potential fix or work around … ?

Big blocker on my mod project.

**I’m aware I’m asking on something specific - old UE4 version + specific existing game Modkit, but who knows maybe someone hit some similar wall before ? **

The worse part is two months ago I’ve got this landscape grass type thing running fine in this very same context… I haven’t changed anything since and tried remaking a project from scratch with very simplest landscape grass setup.

In-Editor setup :
(And it displays this way too if I hit Play)

Runtime:

The two human_reference models displayed here were drag n dropped in the scene as regular objects, just to make sure mesh itself is displaying and grass isn’t .

video of all I’m doing to get there:

https://www.youtube.com/watch?v=LwylOingBX8

Missing collision on the landscape perhaps?

That, or you changed/moved the landscape by mistake invalidating the coordinates, but something Should display somewhere.

Is the layer for grass acrually painted/applied? It should be, given we see the b/w but is it really?

Checking out if it can be about collisions but I do have them as far as I know - also it’s walkable ingame so yep I would think they are okay.

So I’m not using the paint layers but texture maps instead (in this example a black and white checkerboard)
Now I see what you mean with the layer, if I add one like if I was using it, it doesn’t change anything anyway :confused:

More speaking screenshot:

Just tried:

  • Leaving the landscape where it is when you create it rather than moving it to 0. 0. 0. - Same result
  • Painting some height to ‘refresh’ the scattering or whatever but didn’t fix it neither.

Just tried:
Having a paint layer (even though I do not intend to paint anything) : same result

BTW, It seems I can’t erase areas even when specifying target value: 0.

You cannot erase areas if you have only one layer.
you would need an empty layer that has an empty grass type assigned.

That siad, aren’t those screenshots showing it works? Are those meshes placed with the grass tipe or not?

It only works in editor but not at runtime :confused:

No clue. Maybe the grass maps are somehow being prevented from generating…

Would you know of a way to ‘print’ some ‘logs’ ? So I can try and understand what happens or what not happens ^^ ?

Not for the grass generation. As a general rule of thumb the log file is written all the time, you just need to find to where and pull it up…