Download

UE4 4.19 crashes

I keep facing constant crashes with version 4.19 within a minute or so of opening any project. I can’t figure out any possible causes and no one seems to be facing crashes like these. Any help?

First of all, try removing all the cache files of your project.

If you’d still experience crashes, you need to post call stacks from Crash Reporter. Or found in the log. Otherwise nobody would be able to help you - we’re not magicians after all :wink:

I have the same kind of problem long time ago… I couldn’t manage to fix it.
I would suggest you to create a new project and try to salvage all data from that corrupted project.

Another suggestion is to avoid grabbing too many tabs to viewport.

It says I don’t have any debugging symbols to display a call stack. I tried reinstalling the engine, using new projects but the engine simply refuses to work. The engine keeps crashing.
Found this in the log when I searched directory from the crash dialog box.
“DXGI_ERROR_DEVICE_REMOVED DXGI_ERROR_DEVICE_HUNG”
Turns out Windows OS is “conspiring” against me by rebooting the graphics card in some super scientific way that a layman like me can’t comprehend. This error seems to have happened to other ue4 users long back though. I’ll keep posting if I end up fixing it somehow.

EDIT: Tried using first person template over 3d sidescroller where I have the issue. I managed to do the very same blueprint operations (basic) in it without crashing unlike the side scroller. But this doesn’t make sense for the above error code, because that points to a system issue. How on earth can this bug then be selective to a template?

Well, because of different data? :wink:

Select your engine’s version in Launcher. Go to Options and mark “Editor symbols for debugging” to download. It’s 17 GB, probably not included by default.
After getting symbols you should have a proper call stack.

It could be an old GPU crash that couldn’t be fully solved without stable reproductions steps for all of the causes.

On the data part, the different templates just seem to have different thresholds before they crash.
On the old GPU theory, a dialog box opened up like 20 minutes I closed the editor and launcher, saying my graphics card doesn’t meet the minimum requirements. I have a 960M. The lowest nvidia gpu that I found for minimum requirement was a 470. Most absurd of all is that I never asked or gave a command for that dialog box.

It’s really funny because I have this problem on CryEngine and I migrate to Unreal Engine because I don’t have crash on it :smiley:

Okay, it works now ONLY if plug my laptop to a charger. I’m guessing it just removes some limiter, which prevents the graphics card from hanging, which most importantly of all, tells windows to stfu and mind its own business instead of pissing off their average consumers.