Download

UE4 4.18.2 building the level always requires internet connection

Hello UE4 community this is my first post on this forum.

I’ve been using UE4 for about a week now but i noticed something. Every time I hit Build Level to build the lighting Comodo Firewall asks me if I want to give unreal engine access to the internet. And even though I set the firewall settings in this regard to “remember my decision” it still asks me a second time when i build it and if i dont give it access it wont build the level.

any ideas?

It’s weird that it keeps asking, but it doesn’t actually need it, it’s for Swarm which is the Lightmass manager and supports network rendering which is why it asks for permission.

Hello, it is my first post too.
What firewall do you use? Have you tried reinstall?
Maybe in 400 years something will change here, but I doubt it very much. It is better to buy PoE currency and be a happy man or a pop. A stranger to me like a brother, but I can not say anything about it, always something wrong, but people have learned to buy poe currency and vaal orbs. Sometimes I also greet when I sell PoE Currency, I will not run away when it comes for me. Let me go PoE Currency Paradise when the time comes for me. PoE Orbs too https://odealo.com/games/path-of-exile

Same with ZoneAlarm. Problem is, every time LightMass is started, it creates a unique job with a unique path so ZoneAlarm won’t remember it. ;-(

Agree, Firewall nags are a real PITA. Both of those applications have been doing this forever too iirc…
Maybe they could keep a ‘signature of the binary’ etc, and offer an option to work off that instead???

Comodo Fire Dragon

I see, thanks for your answer, guess its nothing major. Just gonna have to deal with it.

that’s a big problem in places like India where the electricity cuts out sometimes and thus cuts out the net connection.

I found a solution here: https://forums.epicgames.com/udk/udk-development/udk-general-development/211419-lightmass-and-my-firewall

I attach screenshot since Comodo firewall seems a little different now: