UE4 4.12 Editor Crash on Mac at 93%

Opening my project with the binary and source editors of 4.12.0, 4.12.1, 4.12.2 and 4.12.3 on Mac will always crash at startup of the editor exactly at 93% with Xcode reporting a null reference:

[2016.06.22-22.56.47:141][ 0]LogMac: === Critical error: ===
SIGBUS: invalid attempt to access memory at address 0x70000021f340

[2016.06.22-22.56.47:141][ 0]LogMac: FTextFormatHelper::Format(FText const&, int, TFunctionRef, bool, bool) Address = 0x21420d (filename not found) [in UE4Editor-Core.dylib]
Attached Crash Report:
link text

This does not happen when opening the project with any version of 4.12 on Windows 10 (both binary and source) and the source editors on Linux (specifically tested on Ubuntu 16.04). This is specific to the Mac Unreal Editor only.

Additional information about this Mac:

iMac 21.5 " Late 2015.

OS X El Capitan 10.11.5.

Intel i5 2.8GHz.

16 GB DDR3 1867MHz.

Intel Iris Pro Graphics 6200.

Hello Sabun,

Have you checked to make sure you are running the most up to date version of Xcode?

Do you have any peripherals plugged into your pc like a tablet or similar device?

Try unplugging any external devices to see if that resolves the issue.

I am not getting the same crash when starting the editor using a binary source or blueprint project.

Thank you,

Andrew Hurley

Hey Andrew,

I am on Xcode version 7.3.1 (7D1014) which is the latest according to the app store. I’ve run a check for updates and there is nothing to be updated at the moment.

There is nothing plugged into the iMac, but it still crashes when attempting to open the project. I only have the Magic Mouse 2 and Mac keyboard connected via Bluetooth.

Here is the Crash Report folder from this crash where nothing is plugged into the iMac if you’re interested in checking:
link text

If you’ll notice in the callstack of the Diagnostics.txt file in this report and the first report I posted above, it mentions the UStruct class. I’m certain this is a bug in the Mac version of the editor with how it handles the UStruct class.

My project contains blueprint structs which is why I work in Windows. Using blueprint structs and trying to edit them on the mac always causes crashes of the editor.

The project is worked on in Windows. Then I copy the project directory over to the Mac and open it. I’ve tried copying only the essential folders (Content, Config, Source, Plugins) and I’ve also tried copying everything over in one go. Both scenarios play out the same.

I appreciate any help you can provide me with.

Here’s another crash report. This time in Windows I deleted ALL the blueprint structs and cleanly removed their references from any other blueprints, yet still the crash report (both diagnostics and log file) make multiple mentions of some UStruct type and filename not found.

In Windows I used 4.12.0 binary editor, and brought it over to Mac. Both in the binary 4.12.0 and source 4.12.3 editors in Mac, it crashes with the same output.

Is there a way to clean this project from UStruct references I cannot see?

Here’s the crash report after having removed all structs but still seeing it in the crash log:
link text

One suggestion that might help resolve the issue. Try deleting your ‘Saved’ and ‘Intermediate’ folders as these hold references to earlier versions of assets and projects.

Secondly, could you zip up your project and share it with me as this sounds very project specific, so troubleshooting might be easier with it in front of me?

What you can do is share with me the project in a zipped folder, upload it to a shareable google drive link, and provide me with the link in a private message via the Forums.

Let me know if you have further questions.

Thanks,

Andrew H

That is not feasible. I do not currently have legal permission to provide you with the project files. I have already tried removing the ‘Saved’ and ‘Intermediate’ folders before to no effect.

Do the crash logs and crash reports really not suffice in locating this issue’s root?

Providing the crash logs is helpful and required when reporting a crash bug, but we also need more information in regards to the context and how to reproduce the issue.

  • Can you reproduce this crash in a blank project?
  • Did you recently upgrade your project from a previous engine version before the crash occurred?
  • Have you made sure to associate your source files with the upgraded version? i.e. Making sure your .uproject is set for the correct engine version and you have built the engine using those generated project files?
  • Which engine version are you on specifically?

Try right-clicking on your .Uproject file, select the switch engine version, and select the one that you want to use. This will re-associate your project with the specified version.

Thank you,

Andrew Hurley

I am on 4.12.0 right now on both Windows and Mac. I only experimented with the hot fix versions to see if they would be able to open the project at all on Mac.

I have yet to try to reproduce this crash in a blank project.

The project was initially developed in version 4.9, and was upgraded to 4.10.4 when it reached me. In the past month, I upgraded it to 4.12.0 (but I still have the copy from one month ago that’s in 4.10.4).

I have already tried using the ‘switch engine version’, and building the game module through the .xcworkspace. It still crashes at 93%. The project is properly associated.

The crash occurs in the older version of 4.10.4 on mac as well as 4.12.0 just to clarify.

The last known openable version of the project in Mac was the version from 4.10.4, and it seems before cleanly deleting a variable from my only Character blueprint. This variable held a reference to a struct, but this variable was not being used anywhere (doing a search in the editor showed no references). After deleting this variable, the project can no longer be opened on Mac. It’s fine still though in Windows. The struct variable is a struct that holds another struct. This struct was made in 4.10.4 and the variable was deleted in 4.10.4.

I have yet to try force deleting the BP that contains the offending BP in 4.12.0 on Windows and bringing it over to Mac.

If that doesn’t work, or if I run into another problem afterwards in 4.12.0, I may be forced to pickup from the older 4.10.4 version and redo the whole month’s worth of work…

The struct contains a lot of things (textures, models, behaviour tree, numbers, strings) and I’m wondering if the struct is overburdened and not meant to be used like this. It still gets me though, why does this work on Windows but not on Mac? Do they have different rules regarding null scenarios?

96371-offending_struct.png

96360-offending_struct2.png

A couple of more things to try…

  1. Going back to the UE4.10 version, in addition to the Intermediate and Saved folders, delete the Config folder
  2. In the Content Browser, right-click “Content” folder and select “Fix up redirectors in Folder.”
  3. Save all

Hi Sabun,

Since we have not heard back from you in a while, we are closing this post for tracking purposes. However, if you are still experiencing this crash, please respond and let me know if you tried any of the troubleshooting steps that I suggested earlier.

Thanks,

Steve H.