UE4 4.1 crashing and creating massive log files

So I have all my UE4 projects, including samples from the market place, in another HDD with about 500GB of space. Anyways, today I jumped on my workstation and noticed my HDD is almost full, which I knew right away makes no sense. Started digging through and found something disturbing.
In some of my UE4 projects, including samples from the market place, UE4 is creating massive log files within the project directories (within the “Save” folders mainly). These log files are between 6-7GB! Yes, gigabytes! they are all over the place and within a lot of projects. I think I know when UE4 creates them, just don’t know why:

  • UE4 crashes a little more often than it probably should
  • after a crash, when reopening UE4- it takes like 10 mins to start back up (sometimes); it’s like it’s doing something…
  • after it finally starts back up again, if you look in your project directory- wham! you can now find a massive 7GB log file (I believe the reason it takes so long to start back up after a crash has something to do with this large as heck log file)

Has anyone ever seen this before, and if so, how do I stop/force UE4 from creating these insane log files?

Hi Jak, such large log files are unexpected. Can you open up one of them and see what is being written into them? With that amount of log there is likely a lot of duplication (we call it log spam). If we can figure out what kind of log is being spammed, then we can fix it. Thanks!

I tried opening one, but they are so huge, windows throws an error and says notpad cannot open a file that large lol.
Either way, I deleted all that stuff to free up HDD space.
Is there anyway to turn off crash logs? Any way at all?

Don’t use Notepad to open those files. It does not handle large files very well as it tries to load everything into memory at once. Try using another text editor that is optimized for large files. Something like Notepad++ will probably be fine.

In the Engine.ini there is a section called [Core.Log] that allows you to specify log levels for various types of logs. The format of each entry is LogCategory=LogVerbosity.

For example:


I don’t think there is a global on/off switch right now.

Honestly, it would be best if we could identify what is causing the excessive log in the first place, so we can fix it properly. That there is so much log indicates a problem, and turning off the log won’t solve that problem.


Thank you for your report. We were not able to investigate this on the engine version you reported, but there have been many version changes to UE4 since this question was first posted. With a new version of the Engine comes new fixes and it is possible that this issue has changed or may no longer occur. Due to timetable of when this issue was first posted, we are marking this post as resolved for tracking purposes.

If you are still experiencing the issue you reported in the current engine version, then please respond to this message with additional information and we will investigate as soon as possible. If you are experiencing a similar, but different issue at this time, please submit a new report for it.

Thank you.

It’s happening with me too

Unreal is creating huge .log files in logs folder

sizes like 14gb, 10gb and some with 2 and 1 gb
many with less than 1 gb ~600
I delete them when have too many but they come back

ue4 is crashing and using huge amounts of memory too.

It starts with about 700 mb when I open the project, and then it keeps growing while I work.
last time I closed it was using 27gb of ram

Hi gustavorios2,

If you are experiencing a crash, then please provide us with the .LOG and .DMP files that are generated during the crash. Go to this link for details on locating different types of log files: A new, community-hosted Unreal Engine Wiki - Announcements - Epic Developer Community Forums.

Also, when you experience a crash, please hit “submit” on the crash reporter pop-up as well as copy the call stack, paste it in a doc, and link it here.


I’m on 4.7 Preview 5 and as of this latest preview, the editor is pushing out log files as large as 3gb (folder totalling about 10gb). There isn’t any crashing, but I’ve noticed that the engine is now taking up about all of my ram (8gb) unlike preview 4. A substantial change between previews. I can’t even open the log files in any editor because the files are way to big.


This is not typical of 4.7 preview version 5. As a test, you could create a new project and add a couple of actors. Then hit “~” to bring up the console command window. Type in Debug Crash to force the engine to crash (This is intended.) Then inspect the log file. It should be very small.

The log files in your initial project obviously should not be 3gb. If you’d like us to take a look you can post a log file on dropbox and provide us a link to download it.


I just experienced the same thing with 4.8.3.
I have a bunch of smaller log-files in the log folder (around 200 KB) and then some huge ones (17 GB).

Any ideas on what I can do to prevent this from happening again ?
Thanks !

Mmm … Something is really wrong here …
When I try launching the project (a very simple 2D game) it stalls at 95% (I have deleted all log files before doing this). When I open the task manager, I see the amount of memory creep up (it is now at 13 GB and still going). When I stopped working on the game yesterday, everything seemed normal, and hitting the ‘save all’ button gave no errors at all.

Does anybody have any suggestions for me ? I’m feeling quite anxious now …


  1. What, if any peripherals do you have connected to your machine?
  2. Can you provide us a copy of your dxdiag?
  3. Can you obtain a copy of the log when it has expanded to 12GB or so? You can cut and paste it into Notepad++ (but not regular notepad.)?

Hi ,

  1. I had a USB mouse connected to my laptop; nothing else.
  2. Sorry, not sure what you mean (novice UE user)
  3. I have some of the log files saved on my laptop. I tried opening them in various editors when I had these problems … but they were too large even for Notepad++.

I eventually did manage to save my project, so I’m going to describe what I did in the hope that someone else might find this useful.
I also think there’s a bug in the logging system (see end of this post).

After reading similar Q&A here on Answerhub, I decided to ‘verify’ 4.8.3 … and it started downloading some more stuff (incomplete update earlier on ???).
I then deleted the ‘intermediate’, ‘save’, and ‘config’ folders as suggested in other posts. After this, I could open the project again, but not the level I had been working on. After some more trial & error, I found 1 blueprint that would immediately crash the editor when I tried to open it.
I copied that BP to a new project, deleted a bunch of nodes until it would compile again, and then copied that BP back into my project… No more errors …

So, in the end, it seemed that my problem was probably caused by :

  1. incomplete engine update some days earlier (why did this happen, & why could I still work in the editor for a couple of days after the update ???)
  2. incorrect use of a Structure in one of my blueprints

But, that still should not result in a log file of 17GB …
In the bits of log file that I was able to open/read later on (*), I found that the same errors where repeated over & over again (infinite loop in the logging system ???).
Since I’m not the first to report huge log files under certain circumstances, there probably is something ‘wrong’ there.

(*) I managed to read bits of the log by trying to open the project/blueprint & then immediately end the process through the task manager, thus limiting the file size to sth. that Notepadd++ could cope with.

Hope this helped … :slight_smile:


Thanks for taking the time to post the solution to your specific issue. We are looking into why UE4 is generating large files upon downloading and I have added your information to the following bug report: JIRA [OPP-959].

Thanks again for the feedback.

You’re welcome ! :slight_smile:

UE is a great engine, & I love the way UE staff is so helpful, here on Answerhub ! Great job !!! :slight_smile:

i hope this is ok, when i post my problem here, i have the same issue with a c4d project.

when i imported this, in my or a blank project, UE (4.12.4) load this, about a half hour or longer and crash without error or message. (the curious, when i imported it, is the number 4875, this number shows at the third progress bar, no idea, where the number came from)

And now my C: is full and i have this great log files, a lot of… with 16-17gb or 6-7gb.

(i saw the crash! for my understanding, the third progress bar load and load… and over 1300?? → UE crash because C: is full, with this log files)

when i imported this in unity, i have no issues.

sorry, for my english… :wink:

thanks for feedback!

Hi Wahnfried,

I’m not familiar with Cinema 4D or the Unity work flow but the fbx you are attempting to import into UE4 is importing as 4875 separate assets (including bones, materials, textures, meshes, maze etc.)

Each pellet that “Pac-Man” would eat is importing as a separate skeletal mesh, whereas, in the UE4 work flow, you would import this as one pellet and create multiple instances from that one.

Also causing an issue was there was no smoothing group information which is typically included when exporting an FBX from a 3D program.

As I mentioned before, I am not familiar Cinema 4D or what your end goal is but I recommend importing each asset into UE4 separately and building the game from instances of these assets rather than 4875 items all at once. Perhaps there is a way to group these for your purposes…

You may want to check out the following Forum post on:

Cinema 4D Workflow


thanks for the response, i will read the workflow…