UE4.4.0 release compile error

I unzipped Require1 and 2.

Using vs2013 ultimate update 2.

It says error: can’t open include file “CoreUObject.h”, No such file or directory.

Hello, can you give me more information?

I assume you’re talking about downloading 4.4.0 from Github and compiling it yourself. You got the Source Code, Required1 and Required2, ran GenerateProjectFiles.bat, and then you Built it in VS, right?

Here is the tutorial I used when I installed UE4 from GitHub: A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums

Thank you very much. I compiled 4.0 4.2 and 4.4, sometimes it’s okay but sometimes not. Just for 4.4, I did the same thing at home and at company, but ran well at home, compile error at company. The colleague next to me got the same error, while he ran well at home, too! Just weird.The error seems to be can’t find the .h file, but it didn’t work even if I added the path of .h file in the UE4 property page.

This doesn’t seem to be a known issue. Did the non-4.4 versions of the engine compile correctly at work? If you and your coworker are both having compile trouble at work, that’s definitely a concern. Are you using the same version of Visual Studio at work and at home?

I got 4.2 worked at company with the same visual studio. My coworker just installed vs recently both home and company.

It seems most likely to me that something about the computing environment at your company is interfering with the process. Is there any chance you could try compiling the engine on another computer at your company?

The fact that you’re only having trouble with 4.4, and only at work, makes me think that some code in 4.4 (that isn’t in 4.0 or 4.2) is being blocked by some kind of software on your work computers. If that’s the case, you’ll probably have to speak with whoever set up your work computers to see if they have some very aggressive antivirus that might be interfering.

Hi crosslife,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.