UE4.27 - Shader compiles on each simple editor start

I am simply starting the UE4Editor.exe with 4.27.0 - getting into shader compiles:


Quad Core i7 - running on 80% CPU for around 7 minutes until getting to the Project Browser to create my new project. Well, ok, could live with that, if it just happened once on first start.

But now the problem: Cancel the project browser without creating or opening a project and just restart the UE4Editor again after waiting a short time to be sure, process has finished.

Guess what happens: again running through the compiler hell - is it really intended to recompile shaders over and over again when opening the UE4Editor.exe.

As comparision: doing the same in 4.26: takes around 4 Minutes to get into the Project Browser to be able to create or open a project. And no shader compiles happening during that time, CPU at max with around 15% and fans keep calm.

My issue looks similar to this old thread, which never got an answer.

My DDC has been moved to a HDD because of limited space on my system SSD. Here’s an image from an existing project:


But even with HDD which might be slower: once compiled, why do it again and again? And, in 4.26, my DDC is also located on that same HDD.

Unfortunately, it’s even worse:

Now creating a new project after waiting for the project browser until it has compiled its 1300 shaders - simple first person template. And again, these ~1300 shaders compile after creating the project.

Even worse: Closing the project, open again: same issue, takes 1300 shaders to compile until project is opened. On every open this happens.

Strange: I have another project in 4.27 - and this does not show that problem. It takes some time to open on a freshly booted system, but on the running system, it opens within a few seconds, if it was opened before.

This is a project, that has been switched from older version 4.24 using the “Switch Unreal Engine Version” function. So I thought, it might be related to that.

Doing same now with 4.24 - new project from first person template - created within less than a minute. Close Editor - switch engine version to 4.27. - open project: 1300 shaders compile. Wait until done around 8 minutes. Save all and close the editor. Check, that all processes are finished. Open the project again - and voila - 1300 shaders again.

Also tested to create project in 4.26 and migrate - same effect.

So this can be reproduced (while I do not know, why my ported version of the Multiplayer Shootout from 4.24 does not show that behaviour)…

For now, I have to wait endlessly to open my new project and waste tons of energy…

Anyone with same problems?

I now tested on a system with all settings for DDC left at default, running on fast NVMe memory and 12 Cores AMD. I can confirm, that the problem is not related to the change of the DDC settings on the other system - also here, it behaves exactly the same. Only difference is, that shader compiles are done in 40 seconds instead of 7 minutes.
So less pain here, but still, there’s something bad going on, and in terms of energy waste, it is not acceptable.

I also tested with UE5 EA version - works fine. So the problem really seems to be something specific to the 4.27 release.
Also tried to delete AppData\Local\UnrealEngine\Common\DerivedDataCache - as mentioned in an old Answerhub post for 4.18 - no effect.

I have submitted a bug report now - fortunately, the Bug submission form seems to work for me again :grinning:

@herb64 I have the same problem. When I open the 4.27 editor with projects list it recompiles shaders. However, when I open any project everything is fine.

The issue has vanished now. Today I updated to 4.27.0 Preview 3 - opening my simple port of the multiplayer shootout project took 45 minutes with endless shader compile activity - but only once, which is ok.
It looks like the problem has been fixed somehow under the hood - I never did get any reply on my opened ticket and also cannot find it on issues site.