UE4.26 - Spawned Actors Not Affecting Nav Mesh

I have no idea what I’m missing here. I can’t get my nav mesh to update at runtime from spawned actors. My AI and my characters will run straight into dynamic obstacles and will run into each other without avoiding anything that is spawned into the world.

I have ROV avoidance working on the Character Movement component but I don’t think it’s relevant to this issue. The nav mesh never seems to be removed beneath these actors.

I’ve also messed with the nav area class and checkboxes but nothing seems to change.

Nav Mesh set to Dynamic:

Settings on Capsule of Spawned Actor:

Nav Mesh not Updating On Simulation:

Characters Not Avoiding Barrels or Each Other:

1 Like

Bump

1 Like

Try to set your nav mesh recast to be dynamic

The nav mesh is set to dynamic at the project settings and is correctly setting nav meshes to dynamic in the levels, so this is already done.

What about the objects themselves, are they affecting nav mesh?
In the Collision settings of the actor that you spawn check for Can Ever Affect Navigation.

As an option if nothing works, try to delete Nav mesh from the level and recast nav, and recreate this. For my project I had to do so a few times, no idea what was wrong, but I had issues with the units was unable to walk even with nav mesh was there, removed, added a new and everything works fine.

Try and let me know.

Best regards

Thanks for the suggestions.

I’ve actually updated to 4.27.2 to see if it was maybe an issue with 4.26, but it didn’t seem to help. All of the actor capsule components (and meshes, and variations of both) have Can Ever Affect Navigation set. I’ve also deleted the nav mesh and rebuilt but nothing seems to change. :frowning: Been stuck on this issue for a very long time - I’ve mostly just ignored it but now I really need to get it fixed!

I’ve also played around with different collision profiles and making sure visibility and pawn are both set to blocking, but still no change. (see screenshots above)

I’ve also added nav modifier components and they don’t seem to affect the nav mesh either. Only actors placed in my level seem to work at all, even the ones that aren’t working when spawned at runtime.

Strange, hard to tell. need to see your level and actors to check all the settings, plus project settings as well.

I feel like everything related is posted. The navmesh settings are the same as the project settings. The navmesh is set to dynamic and the actor capsule collision is set to affect nav. Their collision also blocks visibility and pawn and their profile is dynamic.

What else should I even need? From a fresh project in 5.3, I have the same issue. Its literally only spawned actors.

Here is my game development in 4.27
I use the following actor to spawn:

Look at navigation settings:

Let me know if it helps.

BR.

Thanks for trying to help - this has been bugging more the most since I’ve started development with Unreal lol But I do not see what I’m doing incorrectly. I haven’t checked since my last post - feels like there is no solution for me right now. Ill start from a fresh project and check again, but I really do have the same settings as per above. Ill wrap back to this eventually but something isn’t working as expected. Idk what could be under the hood causing this, but my settings match yours and all of the other posts showing the same thing. Really at a loss.

Can confirm a fresh project works fine. I copied over the DefaultEngine file and made sure all settings were the same for actor capsule collision in both projects - no change :frowning:

I’ve also deleted the intermediate folder so no cached setting should be applied but I am still having the issue.