Download

UE4.26 - In-game Stuttering with high FPS, why?

Hi, I updated my UE4.24 project to UE4.26.2, and I have a lot of stuttering issues, not sure why, because my FPS is between 90 and 120, I already tried “Smooth Frame Rate” (min 22 inclusive, max 120 exclusive), I also found other people with this issues in the same engine version, and some of them fixed it by disabling “enable transport” in the project settings, no idea what that is really but unchecking it does nothing,

I tested a fixed frame rate to 60, it makes everything to move in slow-mo, but the stuttering is almost gone, once I check “smooth frame rate” in the project settings, if I uncheck it, my frame rate stays smoothed too.

My screen resolution is 2560 x 1440, and I figured out that playing in full screen causes more stuttering, but If I reduce the PIE screen size, manually grabbing the edge of the screen with my mouse until I make the window very small, it looks much better, way less stuttering, but I did not had this problems with UE4.24, do you think it has anything to do whith my screen? because my settings are pretty low, no reason to have any impact:

scalability UE

Not sure what else I can do, please help.

I don’t exactly what’s causing your problem, but if you find that things go more slowly when you reduce the fps, then you have a coding problem.

I’m assuming you’re working with tick to move object? You’ll need to multiply by delta seconds to correct it. Come back if you don’t get what I mean.

Your frame rate will dive when you go into full screen, and get better which you reduce the viewport size, that’s normal.

What actually is stuttering? The whole picture, or the movement of objects etc?

Its a third person project, 100% blueprints, and my stuttering happens to the entire game, not just to my character’s movement, stuttering is when every 1 to 2 seconds, the entire game keeps constantly freezing for a micro second, like, if I jump, there might be several small freezing steps, and it happens all the time. I do use “get world delta seconds” for moving my character, but this constant freezing or stuttering happens to the entire game, and I did found other people having this issue.

Do you think my PC monitor should be in a different screen size setting? what should be the regular size for a regular player? I though 4K was ideal, but this is my max size:

image

You can run your screen at any res you like.

Like I say, higher res, lower fps, same for everyone.

When your game is running at low fps ( you can try console command t.maxfps 20 ), if stuff seems weird, you will need to fix this, otherwise everyone with lower power hardware will have the same problem.

The stuttering sounds like it’s a GPU driver problem, have you tried downgrading to the ‘studio’ driver?

My project is running between 90 an 120 FPS, because I set max fps to 120, if not UE4 tends to run even at 300fps, which causes the GPU to overheat sometimes, when you actually don’t need such a high FPS.

I have AMD, not Nvidia, not sure if there is an AMD setting that I can modify to fix the stuttering.

I see posts related to UDP being enabled in project settings:

It’s a long shot…

yeah, that’s one of the reports I found, but like I said, changing the transport setting, does nothing from my end, here is a good example of stuttering, however… it looks like this dev is having this issue in the UE4.26 viewport, while I am having this issue In-game, after I click play (New editor window PIE) and start playing (my stuttering is less intense but more recurrent):

I remember this example, it was caused by another program running on the machine. Can’t recall what…

I shared this video as an example of how stuttering looks like… not that my computer is running another program… just an example

I get that, but have you tried killing everything else progressively?

Since the level looks simple, probably can you upload somewhere so that we can test it?
Most likely it is something in your pc… it can also be an asset with insanely high texture (stutter when it uploads to gpu)… but maybe not as the level is simple.

Edit: And also, look at task manager processes list… there could be one or two process that suddenly demands lots of cpu/gpu time…

It has nothing to do with other software running at the same time, except unreal engine… Everything is off, my PC doesn’t even start programs from init, precisely to avoid other software running in the background.

This is a problem in Unreal 4.26, a problem that I do not have if I close my UE4.26 project, and I load the UE4.24 version (same project)

In the past, If I had an stuttering problem, all the options and tweaks mentioned up in my post, fixed this issue… now with UE4.26, I do all those tweaks, and stuttering keeps going on.

1 Like

@DraxFX did you ever solve this?

We were running into stuttering at high FPS and disabling framerate smoothing by default seemed to fix it.

It stoped happening when:

I changed all my lights to dynamic, set a max draw distance, for the light source set a dynamic shadow distance of 7,000 and turned OFF from any other point light: cast static shadows, affect translucent lighting, disable all ray tracing options (cast shadow, reflections, cast ray tracing global illumination), not sure why static lights and raytracing where not affecting my FPS that much, but indeed affecting my grahics with stuttering, even after building lights, all static lights are gone now, even for my blueprints (torches and actors) and everything is Ok now since a while ago.

Notes: Smooth Frame Rate is still enable, turning it off did not had any impact.