Download

UE4.26 - How to prevent actors returning to the initial position at the end of a sequence?

Hi, I’m making an scene where a fake character is moved by water from one point to the next, the problem with the sequencer, is that once that shot is over, the actor returns to the initial position, the sequence is not respecting the new transfroms, like if it it rewinding, to try to avoid this I already used: “pause at end” but it does nothing, the sequence keeps rewinding to the start state.

I even tried to make the fake actor invisible in the end, but it keeps rewinding making it visible again.

Please help

Double-check your last frames of action that the animation covers all the way to the end and beyond and that you don’t have 2 keyframes overlapping at the end. Does your end frame need to be moved reduced a frame or two?

Set Track → Properties - > When Finished to Keep State.

Are you playing the sequence with a blueprint or simply hitting [play?

Hi, this sequence doesn’t involve cameras, it is just an small boat, once you get to the boat, an actor appears and moves the boat through water until it reaches the final location, but, in the end, when the sequencer finishes playing, both the boat and actor return to the origin, like, if the sequencer is rewinding, without playing of course because loop is disable,

I tried with “pause at end”, “don’t loop” but it doesn’t work, “restore state is disable”, and now I went to the boat translate track as you explained, went to properties choose “when finished to keep state” and same thin, the boat and actor immediately return to the beginning of the sequence.

This sequence exists in the editor, and once the player reaches the boat, a BP makes it play, which is the regular approach.

I cant move the boat to the end location first, to make sure that when the sequence is over the Boat stays at the end… because, the player has to arrive to that boat in the first place and trigger the sequence once it is inside, so the boat has to start from the initial position, I just dont want the sequencer to rewind.