UE4.26 - Alembic/FBX animation caches not syncing up

Hey there,

I’m struggling to get a match in the animation when importing an FBX and Alembic cache of the same animation from Maya. I’ve tried about everything I could, and based on searching around the forums it might still be a problem?

In the example below, I’ve just animated a cube, and purposely put in keyframes that are close to each other, and some further away (can’t really limit what animators may do). You can see in the screengrab that the cubes break away from each other (this is frame 2 in the file). Green cube = Alembic, Blue cube = FBX

It appears to me the FBX cache is not correct. I’ve attempted to import by setting the custom sample rate to 25 and also tried leaving it at 0, but I get the same result.

I’m currently working in 25fps, so I’ve made sure that the sequencer is set to 25fps, and when I export from Maya everything is 25fps as well, along with trying to set t.maxFPS to 25.

I think this gets a bit worse once you start applying this to a character that is jumping around for example. The difference of the separation is much larger then what you see with the cubes.

Here is a zip containing the maya file, along with the cached files in case anyone wants to have a play around.


Any help would be greatly appreciated!