UE4.25 crash [File:Runtime\Engine\Private\Materials/MaterialInstanceSupport.h] [Line: 39] is bug UE-95412

It took me a while to match my crashes with issue UE-95412 because the listing redacted the error code, so I’m linking them here for anyone else searching.

If you’re having this issue, head on over to UE-95412 and add your vote there to the issue so they know if it’s affecting people.

The error does not happen when running in Editor Preview (PIE), but when I run a packaged build in UE4.25 (currently 4.25.2), 90% of the time it crashes with this error:

Assertion failed: IsInRenderingThread() || IsInGameThread() || IsAsyncLoading() || GIsSavingPackage [File:Runtime\Engine\Private\Materials/MaterialInstanceSupport.h] [Line: 39]

Or when running Stand Alone game from editor, the error message is:

Assertion failed: IsInRenderingThread() || IsInGameThread() || IsAsyncLoading() || GIsSavingPackage [File:D:\Build++UE4+Licensee\Sync\Engine\Source\Runtime\Engine\Private\Materials/MaterialInstanceSupport.h] [Line: 39]

Update: I just updated to 4.25.4 and still get the same error stack (though a different line) when running Stand Alone. (I assume this just means that unrelated code has been added to that section but the issue has not been addressed yet. Bug tracker suggests 4.26 will fix it)

Assertion failed: IsInGameThread() || IsAsyncLoading() [File:D:/Build/++UE4/Sync/Engine/Source/Runtime/Engine/Private/Materials/MaterialInstance.cpp] [Line: 622]

Same error here.

having the same problem. added a vote and sent in my logs/crash reports as well.

having the same problem. added a vote and sent in my logs/crash reports as well.

I’ve had this same issue after using Unreal’s Sequence Render, my project refuses to launch for this same error. If anyone can draw attention to this thread then a solution would be appreciated.

A week ago it was marked fixed for 4.25.4, then a few days ago the fix was presumably tested and failed by QA because the status was reverted to unresolved, target fix for 4.26. Just today it changed again to Fixed for 4.26. So that’s good news! But fingers crossed the fix works now and doesn’t get failed again.

For me, this specific issue was when trying to use a material instance on a text render component in a blueprint actor. It seems that using a master material will work.

yes I can confirm that this was also the problem for me! I would have crashes on using Open Level Blueprint and play in Standalone mode. I went crazy on trying to find all the material instances that I made and obviously didn’t think about the TextRenderActor. I did try the 4.26 and I did not have the same problem.

Same issue! Good to know it’s not some esoteric bug nobody knows about yet, but is actually already being worked on.

Still having this issue.

Can’t believe creating a material instance for a TextRender is causing this to crash 100% of the time.

For me was the same issue also about the text, i just swap to material instead of instance and it is ok now no errors

Same issue about the text, swap to material instead of instance , works great

Same crash here but I don’t have any text render component

I don’t have any Render Texture on any Blueprint Actor, but it still happens.

If you all are still having problems (those of you with no text renders in your project), you can narrow down the material instances used in your project by selecting a content folder and having the Material Instance && Used in Any Level filters applied. Specifically, it’s good to do this on the Engine Content Folder (you’ll need to enable visibility in the content browser view options, if you don’t have it). If that isn’t your issue, run those same filters with the root content folder selected to narrow down the problem material. Somehow it must be an non-default shader type, such as the one used for the DefaultTextMaterialOpaque.