UE4.25 cpp project not initializing include path

Recently I tried to make a new project in UE4.25 using the c++ template but for some reason I’m having issues with the initialization. I tried making a new c++ class and that worked fine but as soon as I opened the project in VS I was met with over 13k errors. Upon further investigation it turns out the include search path field under NMake in the project properties was not getting filled out. Initially I thought this issue was caused by something I did wrong but first I wanted to do a couple tests. So I Installed the previous version (UE4.24.3) and made a new project with that, I tried to create a new class and lo and behold: it worked with 0 errors. I understand that due scientific process involves being able to replicate the error so I installed UE4.25 on my laptop as well and was getting the same problem there. All that being said, does anyone know how I can resolve this?

I get the same problem, have to stick to 4.24.3!
Did you solve the problem?

Same thing with version 4.6 - stuck at 39%