UE4.22.2 - NavMesh dont show up - SOLVED

Hello UE Community, i hope someone can help me because the a is big problem for me.
Recently i updated to the UE4.22.2 and now** my NavMesh Bound Volume isnt green or red anymore, its just invisible or not there.**

  • Yes the Volume touches the ground
  • The Ground has a collision (BlockAll)
  • I pressed P and nothing happens
  • I activate it in the “Show” Menu -> “Navigation (P)”
  • I can edit the volume but it dont show any color

Has someone an idea for this … :frowning: ?

Here is a screenshot: https://media.discordapp.net/attachm…02/unknown.png


Solved how??

Yeah. How did you solve it?

I dont remember what the problem really was but my most problems with the UE can be solved when you just restart the engine - sound stupid but it can solve a ton of problems
At the moment iam using nav invokers. This can be another reason, why the Volume dont showing up. Nav Invokers only generate they nav volumen arround the character when they start to move
The last thing you can do is go to your project settings and play with the nav volume settings there
One of these 3 points is the solution for my specific problem, i hope its also you solution

1 Like

Thanks for responding. I was able to fix my problem. In my case I had to lower the radius setting (in nav mesh settings and for player capsule and movement). Lowering these settings increased the width of the nav mesh which was my problem.

Nice thats working :slight_smile: I hope you has success with your Project! ^^

I recently encountered this issue while going through the StackOBot tutorial. I fixed it by:

  1. Resetting the location of the NavMeshBoundsVolume to 0,0,0 .
  2. Resizing the NavMeshBoundsVolume by X & Y only. Changing the Z to be too low seemed to break it.

SmokedTuna’s right, a too high NavMeshBoundsVolume z location make it disappear (no intersection with the ground I guess)

1 Like

Thanks SmokedTuna. It worked. I was struggling with the solution.

Thank you; Same issue in unreal 5.2. Restarting unreal solved my issue… Odd.