UE4.16 Remote Build iOS

I am trying to use a remote Mac computer to build a project I have developed on my Windows Machine. I am using Unreal 4.16.3 and was able to setup the connection between both computers successfully with iOS certificates and provisioning profiles. Unfortunately, I keep running on a permissions problem when trying to package the project. I have attached an image of the original problem.

If I use any of the recommendations found here [Can't Remote Build for iOS - Mobile - Epic Developer Community Forums][1] (allowing the Users group to have full control) the permissions problem is solved, but then I get the Warning: Identity file Engine/UnrealBuildTool/SSHKeys/macbichejos/mactest/RemoteToolChainPrivate.key not accessible: No such file or directory. And the output console stops printing as if the packagin operation has stopped.

Any advice or suggestions will be greatly appreciated. Thank you in advance.


The is how I solved the problem, I’ve already posted an answer in another post, I hope it helps you if you are having the same issues: