UE4.15 Morph Targets Not Imported

Morph targets are not importing with skeletal meshes. Trust me, I’m doing it right. Been doing it for a long time now. The morph targets are setup correctly, the import options are set to have it import morph targets. I changed nothing in my workflow from previous engine versions. Tested this by importing the same exact file into UE4.14 and the morph targets show up so it’s broken in UE4.15.

Well, kept on trying to import them over and over and now all of a sudden on my last import it worked. Something is definitely wrong with it.

I’m experiencing the same issue and I would love someone to give us an answer regarding this. Same fbx file imported in 4.14 work perfectly with all the morph targets working correctly.

After import, i reimport the Mesh by use the reimport Button and the Morphs are imported. it seems its a Bug

What I did to get them to import was first import them with no morphs and then drag and drop the file into UE4. Right clicking and selecting reimport didn’t work for me to get the morphs to import. It’s awkward, you have to fiddle around with it to get the morphs to import. But yea, dragging and dropping the file into the folder seems to make it import new morph targets. Simply clicking reimport doesn’t work for adding new morphs. It’s a bug.

Hi all,

There is a known issue in 4.15 where morph targets won’t import unless you actually import an animation with it. However, there is a workaround which is to simply reimport your skeletal mesh (specifically with the reimport button in persona or reimport from a right click in the content browser).

See UE-41383.

-Matt W.

Sorry, it’s not it. My morphs worked well in 4.10, however they don’t work in 4.14, 4.15 nor 4.16 preview. Same file. Same settings. Reimporting or adding animations doesn’t do anything. Changing fbx file format doesn’t affect this.

Hi gstyczen,

Sounds like you’re having a different issue than the other users in this post. Can you write up a new thread and perhaps include some example assets where you’re seeing this? Might help to include which DCC tool you’re using as well.

-Matt W.