UE4.14 Stereo Pano Capture Level Sequence Fixed Frame Rate Issue

Hi everyone,

I’m struggling to maintain a fixed fps playing a level sequence while capturing a stereoscopic 360 video using Ue 4.14 with BPs

I have a simple 300 frames at 30 fps level sequence with a camera moving forward.
When launching the stereo capture, first frame reads fine, but the animation keeps playing while the frame is being calculated
Ending up being way too early, in fact, the sequence reaches its end at the 3rd rendered frame …

I tried the many different solutions proposed in the forums various threads about it :

  • Launching Unreal Editor with a shortcut followed by -usefixedtimestep flag
  • Launching PIE as standalone with -usefixedtimestep in the advanced settings additional launch parameters
  • Using -usefixedtimestep as a console command ( even if I think it’s not supposed to work this way )
  • Setting the fixed frame rate directly in the rendering settings of UE
  • Setting the Forced fixed frame rate in the level sequencer general options

Last thing I didn’t try was to cook the game and launch it with the -usefixedtimestep flag
( But I don’t think it would solve the problem as the editor seems to correctly get the fixed framerate as well, but stereo capture seems to ignore it.)

I feel like I’m running out of options…

Also posted on the forums, in this thread which seems pretty active concerning stereo pano capture questions :slight_smile:

4.11 preview 7 Stereo Panoramic export works! - Architectural and Design Visualization - Unreal Engine Forums!

Has anyone successfully rendered a level sequence at a correct framerate with the stereo capture plugin inside UE 4.14 ?

Thanks for your help.

In sequencer, which element did you give an animation ?

1- You added your character to viewport and you transform character’s camera’s location.
2- You added stereo_capture_pawn to viewport and you transformed pawn’s location.

Which one you did ? Because my frames captured in starting location.

I animated the camera transform. I set the camera to be active at the start of the recording, so it separates from the current character or pawn and grabs the camera view.