UE4.13, Android SDK and VS 2015 Community?


i am struggeling to get a simple mobile project running.
I did a lot of things. In the end i decided to install the full package of VS2015, then the android sdk as explained.
But nothing helps. Now he can not find my android device anymore.

The error before was that the automation tool did not find a path or something. I dont know.

What is the current install order and setups? Is there a solution to get android apps running with vs2015?

Thanks in advance


Install your android device USB driver

Also did you follow those steps:


USB Driver is no problem.

I know these steps. I think they are deprecated.

They say, vs2015 is not supported but it only works with higher versions of ue4.

What i am currently doing is installing vs2015 again after 2013 didnt work with ue4.13.

I have found this link: https://docs.unrealengine.com/latest/INT/Platforms/Android/Reference/

I will do a full sdk install, just to be sure that nothing is missing.

Lets see how it goes. Later more, i am on it :slight_smile:

When this doesnt work, i will go back to the default sdk install and post the error.

Those steps are not deprecated, I used them on 4.12. Also UE4 has ditched support for vs2013, and now only works with 2015

Ok thanks. I will finish the full sdk install. I dont really think it will solve the issue, but just a try :smiley:

The same error as before. i have made i pic:

I have reseted my pc and currently installing everything i had.
I have found out that samsung kies was installed on my pc and so android 5.0.1 was already installed. maybe this caused some variables to have the wrong values.

@NightWatcher: Which features shall i activate when installing vs2015 and shall i use android 1r4u2 or 1r5?

Thanks in advance

After several hours of reinstalling everything it works now.

The workflow is very easy and it works:

Customized Installation VS2015Community

  • Add Visual C++

  • Add Common Tools

Use 4.12!!! I prefer to use always the previous version of ue4.

  • Go to C:\Program Files (x86)\Epic Games\4.12\Engine\Extras\AndroidWorks\

  • Execute the file within that folder and follow the instructions from epic games

  • The tutorial link is already posted from Nightwatcher

Install the USB Drivers for your smartphone. In my case i have a Samsung Galaxy S4, so i searched for “Samsung USB Drivers for mobile phones”. Easy to find. For other Devices you have to search by yourself.

After installing the USB Drivers i did a restart and plugged in my phone. Wait for installing the the necessary software. When thats ready, press Windows+R (Windows) and type in “cmd”. After that a black window is opening. Type in “adb devices”. Your device should be listed. If not, read the tutorial again. The part where to setup and prepare your phone for ue4 mobile developing.

Yeah thats it. Just took me almost 15 hours in a row xD

lol well the same thing happened to me, especially when I wanted to install daydream, and android studio, and I wanted them the share the same sdk, that was a nightmare