UE4.1 VS deletes Android dlls as junk, no Linux package option

Just to make sure I’m understanding your workflow correctly, what all are you downloading from GitHub, and where are you extracting it? Specifically, are you extracting it into your engine downloaded from the launcher?
EDIT: Also, are you getting the Optional.zip and the most recent Linux toolchain? Both are required for Linux.

I went to build Linux Game to test packaging for Linux so I went the normal route. Launcher already downloaded 4.1 so I grabbed everything again from GitHub for 4.1 release and unpacked into proper folder, then executed GenerateProjectFiles.bat.

My Linux crosscompile environment was already set from the 4.1 pre-release so upon selecting DebugGame and Linux platform in VS2013, Build proceeded to first delete all of my Android dlls as “junk” ?!?

Building finished without errors, and I went to the Editor where I did not get Linux packaging option, and in the process I lost Android as well.

I used the Launcher to verify my install which recovered (re-downloaded) all of the Android files previously deleted. In the Editor I got Android package option back.

Upon running VS once more, it again first deleted all of my Android files (junk again) before proceeding to build.

So basically, by getting the source and compiling from it, I lost both Android support and Linux support does not come up.

What gives?

I had 4.1 already installed as a binary through the Launcher.

I got the Required1/2+Optional zips from GitHub as well as the full source again. Unzipped all into Unreal Engine/ top level folder. I also have the cross-compiler already setup from the 4.1 preview.

Once all that’s unpacked, I ran GenerateProjectFiles.bat to get the VS project and then just tried compiling DebugGame for Linux. VS goes to delete all Android files (it claims they are junk) and builds my target without issues.

Once I go back to Editor, I don’t have Android anymore, nor do I get Linux as a packaging option.


First, I would suggest getting the latest cross-compiler from the official release, as it may have been updated since the preview build.

Second, the GitHub source is not intended to be extracted into the Launcher version, and doing so will lead to bad times (as you discovered). Instead, extract the GitHub version to it’s own location and follow the instructions in the readme on getting started.

Thanks, I’ll give that a try. :slight_smile:

Yep, that was it.

Lesson for today, don’t mix and match. :slight_smile:

It will delete files as junk if you don’t have Android SDK (NDK) installed. This is expected, all dlls pertaining to platforms that aren’t available are considered “junk” and deleted before they can wreak havoc in the editor. That is why setting LINUX_ROOT to correct spot is important before you even generate projects.

(You close issues too soon, this needs to be an answer and not comment ;P)

I am having this issue on UE 4.4 on Windows, for Windows targets, with a clean source install.

Every Android DLL and HTML5 DLL is deleted and linked again when I compile my project, making trivial changes a lengthy process (one minute of build for a line changed in a cpp file). Hitting F7 with no actual change will still launch a 30s process of rebuilding DLLs that I don’t need.

Are you really saying that I need to install Android’s NDK, which I couldn’t care less about, to get decent build times for Windows games ? When will this be fixed ?