UE prerequisites installation failed with Error Code R-1638

hi, i have looked at threads with similar problems and followed all the solutions with no avail. i have tried to manually install the prerequisites and i removed the C++ 2015 libraries. tried reinstalling the launcher, ran as administrator and still cant find a solution. i have tried to debug this myself but it just isnt happening.

i would like to ask if i can go to git hub for unreal and download the full game engine without having to use the launcher and if anyone can see what the problem i am having.

here is my error log:

[1818:1828][2016-01-14T12:10:51]i001: Burn v3.8.1128.0, Windows v6.1 (Build 7601: Service Pack 1), path: C:\Program Files (x86)\Epic Games\Launcher\Portal\SelfUpdateStaging\Install\Portal\Extras\Redist\LauncherPrereqSetup_x64.exe, cmdline: ‘’
[1818:1828][2016-01-14T12:10:51]i000: Setting string variable ‘WixBundleLog’ to value ‘C:\Users\Mobeen Aftab\AppData\Local\Temp\Launcher_Prerequisites_(x64)20160114121051.log’
[1818:1828][2016-01-14T12:10:51]i000: Setting string variable ‘WixBundleOriginalSource’ to value ‘C:\Program Files (x86)\Epic Games\Launcher\Portal\SelfUpdateStaging\Install\Portal\Extras\Redist\LauncherPrereqSetup_x64.exe’
[1818:1828][2016-01-14T12:10:51]i000: Setting string variable ‘WixBundleName’ to value ‘Launcher Prerequisites (x64)’
[1818:1828][2016-01-14T12:10:51]i100: Detect begin, 1 packages
[1818:1828][2016-01-14T12:10:51]i103: Detected related package: {A1C97AE7-FB6B-425F-B75B-7A16E1E5639D}, scope: PerMachine, version:, language: 0 operation: MajorUpgrade
[1818:1828][2016-01-14T12:10:51]i101: Detected package: PortalPrereqSetup, state: Absent, cached: None
[1818:1828][2016-01-14T12:10:51]i052: Condition ‘VersionNT64’ evaluates to true.
[1818:1828][2016-01-14T12:10:51]i199: Detect complete, result: 0x0
[1818:1784][2016-01-14T12:10:59]i000: Setting numeric variable ‘EulaAcceptCheckbox’ to value 1
[1818:1828][2016-01-14T12:10:59]i200: Plan begin, 1 packages, action: Install
[1818:1828][2016-01-14T12:10:59]i000: Setting string variable ‘WixBundleRollbackLog_PortalPrereqSetup’ to value 'C:\Users\Mobeen Aftab\AppData\Local\Temp\Launcher_Prerequisites
[1818:1828][2016-01-14T12:10:59]i000: Setting string variable ‘WixBundleLog_PortalPrereqSetup’ to value 'C:\Users\Mobeen Aftab\AppData\Local\Temp\Launcher_Prerequisites
[1818:1828][2016-01-14T12:10:59]i201: Planned package: PortalPrereqSetup, state: Absent, default requested: Present, ba requested: Present, execute: Install, rollback: Uninstall, cache: Yes, uncache: No, dependency: Register
[1818:1828][2016-01-14T12:10:59]i299: Plan complete, result: 0x0
[1818:1828][2016-01-14T12:10:59]i300: Apply begin
[16E0:0424][2016-01-14T12:11:04]i000: Caching bundle from: ‘C:\Users\Mobeen Aftab\AppData\Local\Temp{c6c5a357-c7ca-4a5f-9789-3bb1af579253}.be\LauncherPrereqSetup_x64.exe’ to: ‘C:\ProgramData\Package Cache{c6c5a357-c7ca-4a5f-9789-3bb1af579253}\LauncherPrereqSetup_x64.exe’
[16E0:0424][2016-01-14T12:11:04]i320: Registering bundle dependency provider: {c6c5a357-c7ca-4a5f-9789-3bb1af579253}, version:
[16E0:1ACC][2016-01-14T12:11:04]i305: Verified acquired payload: PortalPrereqSetup at path: C:\ProgramData\Package Cache.unverified\PortalPrereqSetup, moving to: C:\ProgramData\Package Cache{66C5838F-B854-4A55-89E6-A6138747A4DF}v1.0.0.0\LauncherPrereqSetup_x64.msi.
[16E0:0424][2016-01-14T12:11:04]i323: Registering package dependency provider: {66C5838F-B854-4A55-89E6-A6138747A4DF}, version:, package: PortalPrereqSetup
[16E0:0424][2016-01-14T12:11:04]i301: Applying execute package: PortalPrereqSetup, action: Install, path: C:\ProgramData\Package Cache{66C5838F-B854-4A55-89E6-A6138747A4DF}v1.0.0.0\LauncherPrereqSetup_x64.msi, arguments: ‘’
[16E0:0424][2016-01-14T12:11:28]e000: Error 0x80070643: Failed to install MSI package.
[16E0:0424][2016-01-14T12:11:28]e000: Error 0x80070643: Failed to execute MSI package.
[1818:1828][2016-01-14T12:11:28]e000: Error 0x80070643: Failed to configure per-machine MSI package.
[1818:1828][2016-01-14T12:11:28]i319: Applied execute package: PortalPrereqSetup, result: 0x80070643, restart: None
[1818:1828][2016-01-14T12:11:28]e000: Error 0x80070643: Failed to execute MSI package.
[16E0:0424][2016-01-14T12:11:28]i318: Skipped rollback of package: PortalPrereqSetup, action: Uninstall, already: Absent
[1818:1828][2016-01-14T12:11:28]i319: Applied rollback package: PortalPrereqSetup, result: 0x0, restart: None
[16E0:0424][2016-01-14T12:11:28]i329: Removed package dependency provider: {66C5838F-B854-4A55-89E6-A6138747A4DF}, package: PortalPrereqSetup
[16E0:0424][2016-01-14T12:11:28]i351: Removing cached package: PortalPrereqSetup, from path: C:\ProgramData\Package Cache{66C5838F-B854-4A55-89E6-A6138747A4DF}v1.0.0.0
[16E0:0424][2016-01-14T12:11:28]i330: Removed bundle dependency provider: {c6c5a357-c7ca-4a5f-9789-3bb1af579253}
[16E0:0424][2016-01-14T12:11:28]i352: Removing cached bundle: {c6c5a357-c7ca-4a5f-9789-3bb1af579253}, from path: C:\ProgramData\Package Cache{c6c5a357-c7ca-4a5f-9789-3bb1af579253}
[1818:1828][2016-01-14T12:11:28]i399: Apply complete, result: 0x80070643, restart: None, ba requested restart: No

Hi Mobeen_Aftab,

I’m sorry to hear that you are having trouble. Could you please attach your DxDiag and debugging logs to your post? Steps to generate this information can be found here.

You can get the editor from GitHub, but you would be required to compile the source yourself.

I have same problem, Where is the .log ?


We have recently updated the launcher to address some of the prerequisite issues. Please see the accepted answer to this post for the steps to follow.

If this does not resolve the issue, please post back and keep us updated.

Hi Mobeen_Aftab,

We haven’t heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you’re still experiencing this issue, please try the suggestion that I mentioned above then post back here with the requested info.

If you need anything else, feel free to ask.