Download

UE - How to start a media video through the sequencer?

Hi, I need to play a video (full screen) with the sequencer, I created a media track, selected a video, “media” but… when I click play, everything works fine, until the media video moment, it should be played on the screen and nothing happens… and if I add a plane to the viewport (following the documentation), add the texture to it, it’s impossible to make it perfect match the full screen of the camera and position (like Widgets do), or the video is affected by shadows and reflections looking bad.

Then If I try to use a Widget, the sequencer doesn’t understand when that widget finished playing so it can continue with the other part of the sequence from some moment in the timeline, and then, If I can’t control the video from the sequencer and try to make several sequences, it becomes really complicated to handle music and sound effects to perfect match.

¿Is there a simple way to play video clips from the sequencer in full screen? Please help

have you tried making the plane with texture material unlit?

Check out this video. Sounds like what you’re looking for?

Thanks, I didn´t know that thecnique, BUT… that’s exactly the problem I was mentioning, If you add a plane to the scene and play it from there, everything else in the scene affects the video quality, for instance, that video is affected by lighting and shadows, it also looks orange LOL.

For me, it would be easier to just use a widget, (haven’t tried yet, I confess, but it might keep my quality high) my video is 4K and it looks fantastic if I double click over it in my PC folder, but using a plane in UE, makes it look old, weird, poor quality and that’s exactly what is happening to the tutorial video after using a plane, perfect example of downgrade; a widget might keep the quality, not sure about different PC screen sizes honestly, like, for example if you use VLC to play a video, depending on the size of your screen it will add a black edge up and down, so the video will perfect match any screen size, not sure if the widget does that, but at least I won’t loose quality, still… I cant add it as a widget to the sequencer… :frowning: so that I can perfect sync the movie with other effects, because I wanted to also make the sound effects with UE, for that video but I cannot visualize that video in the sequencer.

so weird, that a “cinematic” tool can’t incorporate pre-rendered movies, full screen and high quality right out of the box.

Hi DraxFX, I have recently reorganized and updated the sequencer section of our documentation, including the document for image plates. Feel free to reference the document here, and I hope it helps:

2 Likes

You can make the material unlit. Additional note you control casting shadows and using light channels so there are ways of dealing with shadow and light.

Excellent. Thank you. Any additional and updated documents are better. Looks likesome gaps in documention may be filled in fro ma quick check.
Is there an easy way to show only updated document pages?
I thoughtthe release notes said you still have to use image sequences to reliably play moving images (i.e. do not use videos if you wish reliable playback)?

Is there an easy way to show only updated document pages?

  • Unfortunately, no. However you can check the version tag within any page in the Cinematic Section. If it says 4.27, then it has been updated.

I thought the release notes said you still have to use image sequences to reliably play moving images (i.e. do not use videos if you wish reliable playback)?

  • Videos can be used, but you need to ensure you are using compatible codecs. Reference the following document (not mine) for information on supported video formats. Basically I think h264 should be fine.

Thanks for the update

Really hopingthere will be more documentation or videos on some of the new released tech in 4.27 (such as lens distortion all within Unreal, etc)

Hi, I was able to play the video on top of the plane in full screen, by following the tutorial BUT:

Quality is really bad, my video is 4K, H264 and after adding it to the plane and play it with the sequencer I got:

  • Screen Tearing (when action is fast in the video)
  • A few banding (lines)
  • Different color tones… and this is the more obvious problem, like orange colors looking yellow, gray looks white, white look like… shinny
  • there is pixelation (squares on dark areas)
  • The overall quality is like an extended 640p video… when in fact it is 4K and has high quality.

If I play it from my PC folder by just making double click, using VLC or any video player… it has none of the above; so I thought that all the problems might come from my UE4 lights in the scene, I tested deleting all my lights, Skylight, Directional Light, LightMass and finally I removed my SkySphere, nothing worked, I also tried to uncheck my light channels from the image plane, my material quality is Epic, still not working, 100% cero impact; now I think the problem might come from the material settings, because If I play it in the “media player” it looks good, and I did check “two sided”, choose unlit like in the tutorial, for now… I’m able to play a poor quality version of my 4K video in UE, but… that’s still poor quality,

I can’t show this to an art director, I’ll be ashamed, fired LOL

Is there anything else I can do in the UE4 settings, or in the material to be able to play my video like any video player will? my scene is empty, I was just starting the cinematic in an empty scene, no possibility of other assets affecting it; like I said, it is cool to be able to play it full screen, not cool to watch it looking bad (and it took months to produce and render) at this point I think I’m not going to be able to sync the VFX and music in UE4 as I wanted, I’ll add them in a video editor, but the video still looks weird, any possibility to somehow play it straight from a folder with the original quality and when it finishes it continues with the sequence? that would be a total fix.

Please help :frowning:

Hi, up to this day, I haven´t solved the video quality and shine problem in UE, but this helped:

I turned OFF bloom… sadly If I press G to previsualize… bloom turns On again… and indeed causes some weird brightness
I turned OFF Eye adaptation, this I HATE… it causes this ultra brightness when you are moving the camera, no idea why this even exists, when I jump in a parachute, I never have “eye adaptation” LOL… no chance, unless I keep staring to an strong light directly for 30 seconds, maybe… but it causes my video to have an extra layer of white tones.

After that, my video was still looking weird in the image plane, white colors look bright, some colors look in different tones, and it is playing the video more in 1K quality than 4K with some pixelation, so… there was no choice, I had to go back to my editing program and make those scenes darker and reduce color intensity, now it looks better… still, never as good as in my video players