Download

UE editor very slow with i5 6600K?

See my question here: https://answers.unrealengine.com/questions/524816/why-does-it-take-ages-to-start-load-with-my-i5-660.html

Checkup your GPU settings, sometimes UE launch on integrated GPU as result you have performance drop.

GPU settings? Where? U kidding, UE4 on iGPU? xD

Yes, sometimes UE have issue with start on iGPU when you have Intel iGPU and NVIDIA driver. Its actual for old NVIDIA GPU driver.
So you need manually setup launch UE4Editor.exe only on dedicated GPU.

How can I make sure UE4 using Nvidia GPU?

You probably have to set that through the (NVidia) graphics control panal.

HTH

Its disabled…

The graphics control panel?

No, no way to see if iGPU or Nvidia GPU in Nvidia control panel… I think my iGPU is disabled?

If I were you, I’d get rid of the 2 sticks of RAM, a setup like yours (2x8 + 2x2) is highly unusual. I seriously doubt you’re taking advantage of the 4GB anyway, but do correct me here if I’m wrong.

2 major issues here:

  • the mismatching RAM will run at the speed of the slowest stick
  • by having mismatching RAM sizes, you are effectively running your entire 20GB in a single channel, which is a bummer

While this, on its own, should not make the editor take 20mins to boot, it’s worth investigating if you are getting desperate.
Eject those two sticks and see if that changes anything.

If it does not improve things, check what’s happening with your drive with something like CrystalDiskMark and see what figures you’re seeing for the drive UE4 is sitting on. You can also monitor disk I/O in the task manager, the swap file might be the culprit.

single channel? But they should all run 1333 MHz, quite fast… Will test with only 16 GB someday in future then.

Actually, 2x8 + 2x2 RAM setup will run in dual channel mode.

Is it possible to get your full specs?

My original PC i ran Unreal on took equally as long to start. I eventually got an SSD for this reason. On my newer PC slow boots were as a result of SHADERS compiling everytime I start up. Never found a fix as I just formatted and re-installed windows.
RAM speeds? Not sure if this is really an issue. Dual channel ram shows about 10 - 30% increase in speed over single channel using benchmark software. In video games there is almost no difference in speed.
I have a i5 2400 that I ran a 8gb DDR3 1600mhz(max speed was 1333mhz because of the platform limitation. DDR3 Ram is backwards compatible if you use higher speeds in a lower speed board) I added an additional 8gb stick for 16gb of ram but this did not increase loading performance in unreal at all. At least not what I could notice.

Currently I am running a Xeon e5 1620 with 24gb of ECC DDR3 in quad channel. Frankly I can’t tell the difference in loading on the i5 2400 vs the Xeon e5 1620.

Is this the first time opening a project, or does it take too long every time? The first time the shader compilation can be brutal.

It is with the Squad SDK (which I don’t know which UE version it’s using)… i7 2600k stock clock, GTX 960 4GB, Epic Games launcher + Squad SDK on SSD… (had on HDD first, made no difference). my CPU at 100% load (all 4 cores).

Removed the 2x2 RAM today.

Squad SDK started up within 3 minutes (stuck at 83% for a while but ok :slight_smile: )

Now opened/loading a map (.umap, “initializing world”, taking ages still… stuck at 84%… :confused: all CPU cores @ 100% load with

50% load by UE4Editor.exe,

and THREE (??) “shadercompilerworker.exe” processes running at ~ 15% CPU usage each… ? Is that normal?

no SSD usage, and only 1-11% GPU usage… shouldn’t shaders be compiled on GPU in UE4 ? )

Got this error btw. before I opened the level, any ideas what’s causing it?

69a6b572dc77d92774e4f3aa6ca0836c037333f6.jpeg

Oh and I just experienced a blue screen (Bad pool header, Win 10), had that a few times the last months, but not anymore the past weeks… happened while UE4Editor was compiling shaders.

That will be the drive failing in 9/10 cases, it does not have to be permanent damage and might be just a result of faulty memory corrupting the data and writing back garbage to the drive.

The above error messages are pretty self-explanatory, the files are missing, potentially due to the above-mentioned corruption. The symptoms add up but it’s hard to tell for certain without running diagnostics.

Back up what you need, format, scan, see what the damage is. Luckily, TBs are cheap these days.

Ha it was ShadowPlay ! ! ! Disabled it, now I finally see detailed progress of the loading of the different things! :slight_smile: