UE editor launches but unable to see interface

mouse cursor can interact but cant see what I’m interacting with. The whole interface is invisible, all i see when i hover over something is a black box.

Hey Mechanoi,

Can you send a screenshot or video capture of this so we can get a better idea of what’s going on? Is it the whole editor that is invisible or just certain user interface elements?

Can we also get your dxdiag info?


Here is a link to the video capture and attached is the dxdiag. Yes the whole editor doesn’t appear after it launches. All I see is the icon on the toolbar. I also built the engine from source but I get the same issue. Altho sometimes the source version I see a small rectangular black box near the bottom right corner of my screen, but other than that its the same as you see from the video.

Video -
link text
Dxdiag -
link text

Well, that’s a new one. Let’s try to work through this. I’ve got a lot of questions, so I’m going to list them:

  1. Did previous engine versions work as expected?
  2. Can you try downloading an older engine version and check it out?
  3. If you launch straight into a project instead of launching from the engine version, does this still occur?
  4. Can you check your task manager to see if you have any rogue UE4Editor.exe processes?
  5. Without sounding like a troubleshooting robot, when was the last time that you restarted your PC?


1./2. No, previous versions didnt work.
3. launching into a project also doesnt work
4. I see no rouge UE4Editor.exe in processes
5. I reboot every day since i shut down my pc at the end of the day.

Hey Mechanoi,

Can you try launching with OpenGL?

To do this, navigate to where you have the engine installed (by default C:\Program Files). Go to …\Unreal Engine\4.7\Engine\Binaries\Win64 and then Shift+Right Click in a blank space in explorer. Then select “Open Command Window Here”. In the cmd window, type UE4Editor.exe -opengl.

Let me know if it opens. You can also try with -opengl4


Nice that worked. Altho that is supper annoying that I would have to do this. What would be causing this problem to begin with?

Hey Mechanoi,

I’m not sure why DX11 Editor isn’t working for you. Can you also try launching with -d3d10? I’d like to see if it’s DirectX in general or just DX11.

The GTX 670 that you have should be more than capable. Is there anything unusual about your setup? Examples could be a USB display, plugging the monitor into the motherboard instead of the Graphics Card, running any window management applications?

Have you attempted the “move” functionality or WinKey+Arrows? Just a thought that it could be trying to place the editor on a second screen that doesn’t exist. OpenGL working doesn’t really support that though.


The -d3d10 didn’t work. Altho when i tried the ‘move’ function i can see a large black window appear. In terms of my setup its normal, monitor connects to the GPU not the mobo.

Hey Mechanoi,

Can I get a screenshot of the black window? Also, did you have to move the black window onto the screen or did it just appear when you attempted to do the move?

Also, if you check task manager, how much memory is the UE4Editor.exe process using?

One other thing I might ask you to do is to uninstall 4.7 and re-install it.


So the window appears when i attempted the move, I press the window key and an arrow key then the window appears.

Task manager shows that the editor is using 284.6 MB

I went ahead and re-installed the engine, no change.

I’m no expert on this, but just wondering if your saved ini settings have you out in the middle of nowhere.

In your EditorUserSettings.ini there is a ScreenPosition=X=xxxxxx Y=yyyyyyy

Do you have this file and does it have some crazy value in it? You could nuke the file, but there are other settings in there.

This file should be in MyGame/Saved/Config/Windows, or possible in your MyDocuments folder, or possibly in User/AppData/Local. Sorry it could be in many places, internally I know where it is, but I think it could be any one of these based on your development workflow/environment.

Now how it went bad and why it won’t save something new, I’m not sure, but this might give QA a lead to the issue.

Hey Josh,

I checked the EditorUserSettings.ini but I didn’t see a ScreenPosition in it. I went ahead and nuked it but the results stayed the same.

Hey Mechanoi,

I was finally able to test on a GTX 670 in Win8.1. I cannot reproduce this at all here.

However, I was running back through your dxdiag, and I’m not sure how I missed this, but you’re running on an ultrawide monitor. If you have regular 1920x1080 monitor lying around, can you try that? If not, can you force your monitor to display at 1920x1080? We don’t have any ultrawides to test here and I want to see if that’s the issue.

I can only imagine that the GTX 670 might be struggling with that much resolution. Although it’s less overall resolution than two 1080p monitors, it may not handle one high resolution screen as well as two lower resolution screens. Just my thoughts right now, but I await your results.


Hi Mechanoi,

I’m marking this as answered due to inactivity. Simply reply to this answer to re-open the issue.

I’d really like to continue investigating this as ultrawide monitors are gaining some traction in the market.


Hey . Sorry been out of town but I will double check using a different monitor when I get back. But I also wanted to say that even though -opengl fixes the visual issue I had, the engine would lag and crash when I would try to mess around with it.

Cool, just let me know if it helps. I think the ultrawide + the editor with your GPU might just be too much for it, but we will see.


So I figured out what was causing the whole engine to bug out. Since we nailed it down to a rendering problem I realized that I had Virtu MVP running this whole time. I turned it off and voila everything ran perfectly. So the culprit here was a program called Virtu MVP that was utilizing both my dedicated GPU and the integrated GPU on the Intel processor. I don’t know how I didn’t realize this sooner. Thanks for spending all this time to help me out, much appreciated mate.

Thanks for posting your findings. I’ve proposed that we start a public wiki page of software that has been known to cause conflicts with the Editor. I’ve already started compiling a list.