UE crashes when importing with Datasmith for C4D after 5.0.3

After updating to 5.0.3 I’m not able to import or reimport anything in Unreal via Datasmith for C4D, UE crashes. It’s not due to the C4D files as the same files have been imported in the project on another PC without any trouble. The issue began with 5.0.3 and a total (re)download of the project in Sourcetree during a pull. I clearly can’t work anymore with that issue.
Any idea ?

I’m having the same issue with Datasmith and 5.0.3. No solutions, but I’d like to follow this thread.

At least we are two us !
UE 5.0.3 has been reinstalled from scratch, same for SourceTree, the project has been entirely re-downloaded and the crashes are still there.
I wanted to upload the crash reports (.log -xml .ini) but sadly I’m not allowed .
Where are this dll supposed to be : aqProf.dll - VtuneApi.dll - VtuneApi32e.dll ?

Do you have Cineware installed on your machine?

The logs files are in your project>Saved>Logs folder.

I have two other forum users having crash after migrating to 5.0.3, I am checking with dev.

Sharing on behalf of @LoicDerrien as we’re collaborators, and he lacks the ability to upload due to account age.

503_C4D_Datasmith_CrashReport.zip (315.3 KB)

I believe Cineware is a component of C4D, but I am not as qualified to help in that particular question, having never used C4D before myself.

Cineware seems to be here, as it was before.
I always “save for Cineware” in C4D before importing in UE.

It always crashes here, when loading cineware modules

Can you all check out if the answer from AKnauerMaxon posted here solves your issues

You saved my day, my month and probably my year ! :sweat_smile:
I works perfectly. Than you
The config.cineware_dll.txt comes complete in R25.120, but NOT in R26 and that is quite incredible.

The C4D Datasmith plugin in Unreal is not ready yet for R26,
and the config will be in the plugin itself, avoiding this issue hopefully in the future.

Hi Flavien and AKnauerMaxon,

Thanks again for the fix but, it works for new import and reimport but reimporting a C4D file imported before 5.0.3 gives catastrofic results unfortunately.

UE sees the right source and I can open the file in C4D without any problem from Unreal via “open in external editor”. But the reimport is broken. I don’t know if it’s Cineware again or Datasmith this time but it’s a big problem for us as there are always small fixes to be done.

you see the result here as I can’t upload two files as a rookie.

Just an update :

Concerning an import made after the fix, the reimport doesn’t brake anything and keeps the corrections but you loose the applied materials, strangely not all of them as the only mesh to keep it’s material is the one that has been changed in C4D before reimport.



The external walls was the changed mesh.

Hello LoicDerrien,
if I understand your steps:

  1. You have imported that scene for the first time in 5.0.0, 5.0.1 or 5.0.2?
  2. worked on it a bit, reimported, it worked fine
  3. then updated to 5.0.3 → and the reimport did not work 100%
    Is that right?

Could you perhaps file a bug in Cinema with that scene and “CWUE5” in the subject field?
If that scene is too big to upload, you could maybe reduce it to just one house, that has those unwanted effects.

Hello AKnauerMaxon,

Thank you for answering.
Here are two shots of the whole scene.

All you see on those pictures (except foliage, sea and ground) has been made in C4D R25 117 and imported (without any material) in UE 5 preview, 5.0.1 or 5.0.2 via Cinware/Datasmith. All materials are created and applied in Unreal. Apart a few crashes now and then I managed to import, modify and reimport when needed for months, untill 5.0.3, for the reason we know now.

After the cineware fix, some elements of this scene imported with version of UE before the releas of 5.0.3 still needed to be changed so I made the changes in C4D and tried to reimport. The result is above (screenshots 1198 ans 1199). The reimport results in a broken and partially untextured object. This will happen to any house in this scene if I try to reimport. It’s bit of a nightmare.

Concerning the only import made from C4D R25 120 to 5.0.3 after cineware fix, the import is fine but any reimport will result in a loss of texturing except for the meshes that have been modfied just before the reimport. You see it on screenshots 1200 and 1201.

I opened a ticket on the Maxon website (Ticket #294338) with the two files.
Again, thank you for answering.

same issue

Even after updating cinema to R25.120 ?