Download

UE breakpoint when running [SOLVED]

Hi. I just built the Engine with the latest promoted version of the engine of GitHub to use Chaos Destruction, and I set all the stuff according to this guide https://docs.unrealengine.com/en-US/…iew/index.html (set unique, and so on).

The build had no mistakes, but when running the Engine, following these steps https://docs.unrealengine.com/en-US/…ine/index.html , at 86% shows a breakpoint saying:


 
// This will trigger if an IMPLEMENT_SHADER_TYPE was in a module not loaded before InitializeShaderTypes
// Shader types need to be implemented in modules that are loaded before that
checkf(!bInitializedSerializationHistory, TEXT("Shader type was loaded after engine init, use ELoadingPhase::PostConfigInit on your module to cause it to load earlier."));
 
 

May someone help me out? Thanks

Edit 1: Since I ran the UE4Editor as the startup project, I edited the “ModuleDescriptor.H” in “[PATH]\Engine\Source\Runtime\Projects\Public” in Notepad++.
Changed “Default” to “PostConfigInit”. Saved it, no need to rebuild, just clicked on continue on Visual Studio. It solved it.


...InLoadingPhase = ELoadingPhase::Default);


...InLoadingPhase = ELoadingPhase::PostConfigInit);