Download

UE-62389 -Android mic stops capturing audio after 2nd load of app

I made simple class that capture voice input from mic and I build it for android .

when the app run for first time, the capturing working fine after passing record permission and I can see data voice data output, however, once I close the app and open it again, the Capturing state set to OK but I see no data at all .

If I disabled the mic permssion manually and restarted the app, it works fine once again, close it and open it , problem happen again .

Whats wrong ?!

I’ve checked with monitor.bat , log at first time has no errors, but when I start the app once again i get this strange error E/AudioRecord(24604): start() status -38 and this strange warning "Warning: OpenSLES SL_RecorderBufferQueue -1405068740"

Any help ?

I’ve included the full Log

Sounds like AudioRecord device is not released properly when closing the app. On which version of Android are you testing?
Could you share a small sample project?

Hey mate,
The bug is already confirmed and ready for vote

and yes as you said Its related to that .
There is bug report on answer hub
https://answers.unrealengine.com/questions/813082/bug-audiorecord-start-status-38-error-android-log.html

and for full code .cpp .h , check this thread , its also mine, I did a lot of threads related to that trying to get any attention :smiley:
[IVoiceCapture Get data return 0 on android , while capturing state is OK - UE4 AnswerHub

​​​​​​​](IVoiceCapture Get data return 0 on android , while capturing state is OK - UE4 AnswerHub)let me know if you have anything in mind .

Any Fix yet? :smiley:

Up again, and again, and again .

I’ve moved to FMOD, and the same bug also shown up, what is strange is enabling mic permission manually cuz the same bug, but if I let the runtime permission request AUDIO_RECORD , then it run fine and thats why it run only for first time.

Dont know whats the way around, I really wish to hear from epic games or anyone about this issue.

I’ve found that [Voice]bEnable = true , is the issue even without using the voice capture interface with FMOD, set it to false , make FMOD working fine, but ofcourse I cant disable it if I’m going to work with unreal engine voice interface itself.

I really wish to find any work around.