UE 5.1 - Lumen Reflection - Black Squares on Editor

Hi there

I’d like to register an issue here about lumen reflections.

The editor screen started showing black squares at certain camera angles and excessive glare in some parts during rendering.
At first I thought it could be a cause of bloom or lens flare, then I disabled both and nothing. My Post Process Effects is set with Lumen reflections, “hit light for reflection” and high quality thinking. This issue appears to be related to the “hit light for reflection” option. After changing it to “surface cache” the black squares disappear. it’s weird, in UE5.0.3 this didn’t happen.
It might help someone who is experiencing the same problem.
Let me know if there is another solution for this. Thanks.

Same problem here

Yep, same issue, I was advised it was lens flare-related, so I set my global post process volume to 0, and it significantly helped reduce the black boxes, but has not gotten rid of it completely.

This is how it looked before

DynamicVolumetricSky_Troubleshoot

1 Like

Any real fix for this yet? In my case it seems to be bloom that’s causing it as I disabled it and my render was fine, thing is I really want the bloom effect. Any ideas on a fix?

I figured a workaround for my movie sequence which might help others dealing with the same issue, and that is the set key frames to automate the bloom intensity so the effect is only active when I actually need it, as strangely it only effects the sequence in places where you can’t actually see it, I’ve not done the whole render yet but it looks promising.
If it turns out that it happens on frames where I need the bloom effect I’ll see if I can do two passes, one without it and one with and mask them together in my video editor, a pain but that could also work.

2 Likes

UP. same problem here. The only solution I found was to actually disable bloom/lens flare. Hope they make a fix for this.

2 Likes

Hi,

TL;DR:
Check your Materials, especially ones with transparancy, even if they are not in the view.

So I encountered a similar Problem but it only happened in Pathtracing for me.
Anyway I thought I would share it here, just in case it helps you too.
I had this result:

I found out that the reason was a broken or maybe wrongly used Material:
MI_Glass_Clear from the Automotive Material Pack thats in the permanantly free Collection if I remember correctly.

Whatsoever:
I set the Transmission Color to full black, to hide my missing interior.
Just one mesh using this material somewhere in the level, not even in the view, broke my entire render. Setting it to anything else than full black fixes the problem.

1 Like

I got rid of them by turning bloom to convolution in the post process volume

2 Likes