UE 5.1: Infinite polygons in a low end machine?

In this scene I rendered 25M+ polygons in UE 5.1 using my old war machine GTX 1650.
The scene performed quite well without eating up my VRAM. But the scene started lagging as I increased the Biome size, and it was later confirmed that the reason being the cost of rendering Virtual Shadows and however you try to optimize the shadows with console variables, etc. The performance won’t boost by a lot. Until…

You can enable or disable ‘Show Light Components>Shadows’ while you work in the viewport and it will greatly boost your performance (5 FPS to 60+ FPS) and you can enable it when you decide to Render it using the Movie Render Queue.