UE 4.5 does not appear in Launcher

In my launcher I do not get the option to install Unreal Engine 4.5.

I had installed the preview version of 4.5, but I was having issues when trying to update to the stable release version. So, I deleted the preview version. But, now I do not get Unreal Engine 4.5 as an option in the launcher.

My Unreal Engine Launcher version is 1.8.1-2322947

I need badly to install 4.5 since it has fixed some issues that affected me.

EDIT: I still do not get unreal 4.5 in my launcher. Meanwhile, I have compiled it from source. But, I am afraid that I will miss some integrations with the launcher.

Howdy lefam,

Thanks for reporting this issue. When you go into the Library section of the Launcher, have you select the ‘+ Add Engine’ Button at the top of the window? this will bring up a new slot for the Engine.When you click on the button, a new slot should open just below it. You should be able to select which engine version you would wish to use. Here is a screenshot that may make it a bit clearer:


You should then get a new slot where you can select the version number of UE4 you wish to use:


You may also want to try and restart your Launcher and see if that fixes the issue.


Hi Sean,

This is exactly what I am doing, but to no success.

I have also tried to restart the launcher. Again no success.

Now, I have noticed that after restarting when I go quickly to Library 4.5 appears but suddenly disappears and is replaced by 4.1.2.

Hey lefam,

You are an active subscribers, correct? You do not currently have a cancelled subscription?


Hi Sean,

I am “very” active.

Would it be possible for you to uninstall and then re-install UE4? This has been a workaround in the past and may be of help in your situation.

My currently installed engines will be kept when I uninstall UE4?

Hi lefam,

Instead of uninstalling, could you post your Verbose Logs for us?

Follow the steps at the bottom of this link for directions on how to get them.

Hi TJ,

I have attached the verbose logs. I am running on OS X.

link text

Similar issue here, all I see is 4.5 Preview.

Same issue as Kosyne, only 4.5 preview and uninstalling is not an option right now, unlike OP I am using win 7.

Also have same problem as Kosyne.
I just re-upped my subscription, everything copacetic there.
Now I see 4.1.2, and 4.5.0 preview. No plain 4.5 option.
Reinstalled launcher, didn’t help. Win 7.

Same for me - latest launcher 1.8 and 4.5.0 preview only showing. Win7.

Same as the above. I hit add, it defaults to 4.4.3 and only shows the 4.5 Preview above it. I tried re-installing with no results.

I downloaded 4.5 yesterday, and used it all day today. Now though, when I open the launcher it says 4.5.0 Preview. I can open project files form Explorer though, and they open in 4.5.0 (which is still downloaded on my computer). I’m using Win 8.1. Screenshot below (account blacked out for privacy).

Exact same issue

Same here, on two different computers.

Hi guys,

I believe this is a different issue than the OP is describing above. A fix has been submitted and restarting the Launcher should fix the issue.

Please post back at the link below to let us know if it doesn’t work for you.



Tried restarting my computer and launcher. Neither worked however now as I just got back home and checked my launcher after it has been on for a few hours it doesn’t show the preview anymore but simply 4.5 (fixed with other words). No idea how it got fixed.