Download

UE 4.27 with Remote Control API - calling "Open Level" crashes editor

Hello,

I am using UE 4.27 with the Remote Control Plugin. I am on a Mac, on macOS Catalina. I installed UE4 through Epic Games Launcher.

I am using the Remote Control API to call a function DebugOpenLevel, that simply opens an empty Game Level. See blueprint logic here:

Whenever I call this function using Remote Control, the engine crashes. Inconsistently, sometimes I am able to call the function anywhere from ~1-5 times from remote control, then the same crash occurs. The Crash Report states the following:

Fatal error: [File:/Users/build/Build/++UE4/Sync/Engine/Source/Editor/UnrealEd/Private/EditorEngine.cpp] [Line: 7262] Previously active world /Game/UEDPIE_0_DebugEmptyLevel.DebugEmptyLevel not cleaned up by garbage collection! Referenced by: (root) UnrealEdEngine /Engine/Transient.UnrealEdEngine_0->Trans TransBuffer /Engine/Transient.TransBuffer_0::AddReferencedObjects() (PendingKill) World /Game/UEDPIE_0_DebugEmptyLevel.DebugEmptyLevel

Interestingly enough, if I run the SAME function DebugOpenLevel via UE4Editor Console Command, there is no crashing, and I can run the command in rapid succession without issue. I can also directly call OpenLevel function in the same manner from Console Command with no issues.

This seems like it could be a bug related to Remote Control Plugin, since I only experience UE4 editor crashing when I run this function via the API – when I run the same exact function from inside of the editor, the problem does not exist.

One more note, I can call other functions from the Remote Control API with no problems, e.g. a function with a simple print statement runs fine when being called from Remote Control.

Thanks for your help!