[UE 4.27] How to merge 2 or more Landscapes?

Hello everyone,
I’m experimenting with World Composition, using the “Import Tiled Landscape” function.
I used said function 3 times on the same Persistent Level, importing a set of 3 tiles with each import. As a result UE has generated 3 separate Landscape Actors, now if I try to sculpt between said Landscapes it won’t let me, even after selecting all 3 at the same time in the World Outliner. The heightmap files for the tiles are all in the same folder.

Is there a way to merge those 3 Landscapes into 1? I tried selecting the Landscapes, right click “Merge Actors” but it’s greyed out, I can’t do anything.

Any help would be greatly appreciated, respect

In other words, I’d like to have all tiles be under the same, single Landscape Actor, and delete the remaining Landscape Actors which in this hypothetical scenario due to no longer having tiles in them I would simply proceed to delete, wouldn’t need them anymore. I only need 1 Landscape Actor and have all my tiles in that, it would be really great to be able to use the “Import Tiled Landscape” function however many times I like and be able to move the tiles in my desired Landscape Actor at will

Were you able to find a way to solve this problem/issue? I too have this issue. I, unfortunately, have 4 landscape actors I would like to merge into 1 without redoing everything…

I don’t know how to save the “painted” information on a level heightmap.

So a made a backup of my game first.

What I was able to do was to export the heightmap for that level with the incorrect landscape actor which appears to capture all sculpting changes.

In world composition, unload all levels except the level you want to convert. Select the LandscapeStreamingPoxy for that level in the persistent level. Change the Landscape Actor to the desired actor. Your level should go flat and black. Select the now flat and black LanscapeStreamingProxy. Change the mode to Landscape. Select Sculpt. Right-click on the Heightmap and import the exported landscape. You should get the origional heightmap back with sculpting changes. Select Paint. Select your auto landscape texture. Right mouse click on this and select “Fill Layer”.

This should get this level on the same Landscape Actor as others such that you can walk the parameter and fix any seams that didn’t match so well by using sculpt and smooth.

Then I will have to repaint all of these levels. I don’t know what else I should have done.