UE 4.27.2 - How to build for target SDK 33 (or 34) !

I tried everything. My project is 4.26 and the plugins are for 4.26
The build for Android API 33 builds successfully, even Google Console accepts it. But, as soon as the app starts on the phone (Google Pixel 8 Pro) it crashes. It seems that the issue is with Java, but I am using JDK 1.8. Last year in November I built and packaged the project with the same settings and environment. Any help would be appreciated! Thanks!

The problem is something to do with the Splash Image (SplashActivity) where something is with the android:exported=“true”.
When I untick the Launch Splash Image, the app is stuck on the game icon on the full screen, nothing else.

Any help would be appreciated! I don’t have any more ideas what to do and what to try.

Please who has solved this issue? APK fails to install on device.

doesnt work for 5.0.3 unreal, target api 35

I’ve gone throught with Source code of UE 4.26.2. There are easy tutorials how to install it on your pc.

Then I just added this line android:exported as per the comment above in the same file.

Then, built and installed with USB Debugging without issues.

Thank you for the help!