UE 4.26.0 - Oculus Quest 2 - Project launches (kind of) OK, doesn't start on Device

Hello, I stumbled upon your discussion because I had 80% of your issues for some days until I solved for my Quest 2! I followed step by step this tutorial:

Have to say that worked on a blank project, so… I guess my answer won’t be so useful if you have an entire game ready :frowning: sometimes I recover much of the work by migrating the maps in a new project.

Hope you all solved your packaging errors in the meanwhile

Have same issue on 2.26 , every screen debug message like (Print string, show fps or load level with not builder light map “light map needs to be rebuilt”) immediately crush game. This error on quest and quest 2 same.

Looks like a bug has been submitted - Oculus Quest Crash after I call "Print String" node - UE4 AnswerHub (the picture on the answerhub thread might help Shardfer with his game getting crushed)

Hi, I have similar issue, got a Q2 try to use it on 26.1 I have a project which runs good in 25.4 but when I move on 26 I get the 3 dots and grey screen when it runs there is no errors in the log. I try to play with the sdk version number the build setting and I got it to run in with different setting but I always get the grey screen with all of those. I’m using a Mac, but I don’t see that causing issue with previous version. Dose anyone find a solution yet?

1 Like

Hi, I’m getting that exact message in device output log when my project fails to launch.

#00 pc 05dc65e0 /data/app/com.YourCompany.FouTwoSix-0VUUJ4peETxbWVN9b9xarQ==/lib/arm/ (TRefCountPtroperator=(FRHITexture2D*)+40)

Do you have any idea what is causing this?

I keep getting the error listed at the top here: [4.26] Cannot package for android - #7 by Svit_Drift_M

I have updated my Android Studio (API 29) as is the suggested answer but it didn’t help

Hey all, I have had issues with the 3 dots in the past, Always seemed to be some kind of missing texture or material being the cause. For me WorldGridMaterial missing from being cooked was the cause of my game never making it. If in doubt make a new blank level and set that level as the Startup/Boot Level and see if you can get past the looping dots.