UE 4.24 New Sun and Sky system - exposure

Good morning to all forum users. The new Blue Print Sun and Sky is incredibly intuitive and easy to use, setting a specific location and date and time is very helpful in architectural visualization. However, I have a problem with exposure. By default, automatic exposure is set in the test scene. For architectural visualizations, you would like to use manual exposure, but then the sun is much too bright. Should a smaller number of lux lux be set? How do you solve this problem? In addition, if I would like to create a Scandinavian atmosphere in another rendering engine, I would set the color of the sun to white and increase its size. How to solve it here? Thank you.

Hello @filipekk and thanks for your feedback,

By default the SunSky component features a very bright sun (using physically based value of more than 100000 Lux). So you need to lower the exposition time of your scene by increasing the EV value of your camera or from the Viewmode dropdown at the top of the editor viewport. When using physically based values, it is recommended to enable the extended EV range available in the project setting. If you do not want such physically based value, to simplify how you deal with exposure, you can simply use a lower sun Lux value to something that suits you.

By default, the sky is rendered by the component in an automatic fashion. If you want to compose the sky yourself and have full control on the sun, moon, etc, you will have to use a sky dome and composite the sky with aerial perspective there using all the SkyAtmosphere node available in the material graph. You can follow the example of the new TimeOfDay_default level sky dome shader (template available when creating a new level). The reference documentation for those nodes is there, also please read this. This is where you can be creative and even do things like this.

Hi - I’m having a problem regarding cubemap creation while using those crazy real world numbers. In my scene I’m using the Sun&Sky Actor with the standard value lux and compensate by adjusting the exposure manually in the PPV.

This works great and I can use any light source in the scene using real world values, however, I now wanted to create a cubemap of my scene for the far background by using a SceneCaptureCube actor and the resulting texture is just way too bright. I tried lowering the directional light lux to far lower numbers and then the texture was visible on my cube but all the other light sources were still way too bright in the scene - everythings off. Is there a way to still make a cubemap with these high directional light value settings?

I think that is because SceneCaptureCube does not take into account any exposure setting even when in HDR mode. that would have to be improved. I’ll ask around.

That would be great as of right now I can’t create a cubemap with this actor in my scene. Thank you very much! :slight_smile:

Any progress with this? I’m using render targets to create preview textures for an archviz project. When using the sun and sky actor all textures are rendered white. Which seems to be the same problem mentioned above. Totally overexposed.

The interesting thing is that the render target camera is in an enclosed room which should not let any light from the sun or sky actor in. The 2 pictures show a test room which is just a cube with in and outside walls and no windows. It should be pitch black inside if you ask me but it isn’t. I even tried to put that room into another room to see if that blocks the light. But it doesn’t.

How can I create a room that blocks all the light out emitted from the new sun and sky actor? Did anyone ever try to create a pitch black room or totally independent lighting with this actor in the scene? - Post process volumes don’t seem to change much. The only way to make the room black inside is to reduce the sun brightness to something like 10 lux. This can’t be right or can it?

Any progress? Dealing with the same issue… :frowning: