UE - 4.24 Hair Rendering Bugs?

There are a couple of issues that maybe the Unreal Engine team may want to be aware of. Maybe its a problem with my setup or maybe these are known issues. Anyway some issues I’ve experienced are as follows:

  1. Binding groom to skeletal mesh usually provides problems, on my system it crashes every time. The functionality works by NOT doing this step.
  2. There is some kind of intermittent lighting or shadow malfunction, I’ve tried many different combinations of settings to try and isolate the issue, but what happens is while either simulating the or previewing the groom in the view port the groom’s hairs will become “thick” and as if its rendering in 8bit. It seems to happen if viewing from different angles, but this 8bit rendering is 90% of the time on my system…
  3. You are forced to edit the default hair material, you cannot create your own instance to place in the slot, as it won’t ‘save’

Really the biggest issue is #2. Attached are some screenshots, the good render, is how it is suppose to look, if I back up or move the camera even slightly, then the bad rendering occurs. If I play an animation it also renders incorrectly…any help or advice would be appreciated, if there is a way around this.

#2 After playing with this… it seems the view port preview as well as the simulate, will show the hair guides. In this case when I imported this hair test, I imported it with option of 1:1 guides to hair instead of .01:1 which made this test look blocky in preview.

/edit the guides do appear in final cinematic render

The new system is still - essentially - in alpha. marked as Experimental.
They really haven’t even provided us with a working sample - I have been waiting for one since .24 was released…

Hopefully with the next build they’ll release more - and better docs.
If you want to submit this as feedback, I would suggest a specific post within the feedback section.

As far as getting help with it. I haven’t even been able to actually use the system to test stuff since they didn’t really explain how the groom file is supposed to be created. Dollar to Doughnuts, that’s probably the issue here too.
They did publish that, Understanding what to do with it without a working example is, well, not impossible, but improbable.

Well I did find this,

Some of these steps don’t line up in my experience however I’m going to test this some more and update this thread if I find out a way to hide these guides from the renders.

I found setting Visible to off on the Niagara Physics Component Rendering section hides the guides.

coldpizzapunk, you are my hero. I thought I tried every setting there was…thank you!!