UE 4.22.0 fail to open

Hi there,

I can’t launch UE 4.22.0 Editor after updating from 4.22.0 Beta to 4.22.0.
Everytime I try to create or launch an existing project I receive the Datasmith


as shown in the attached image and Editor doesn’t open, going back to
epic game launcher.

If I try to re-build datasmith stuff, it says I need to compile my project from source manually,
that’s seems pretty absurd.

I’ve tried bot rebuilding and not rebuilding, but this doesn’t change the game.
I’m launching 4.22.0 with -dx12 option enabled to use raytracing.

4.22 Beta was fully functioning and didn’t shown this problem.
I can’t reinstall datasmith because it says that it’s installed on every engine.

I’m on Windows 64bit 1809
How can I fix this?

You need to update to the latest version of the Datasmith plugin. You currently have the Preview version installed.

Click on: “Plugins instalados” and choose to update Datasmith


I just came across this post as I too am getting the same issue. When I went to install datasmith, even though I no longer am actually using it, I don’t get the option for v22 of the engine. See screen shot here:

Any suggestions or is there a way to remove it completely if you no longer use it?
Thanks heaps

I’ve solved with a clean install