UE 4.19 APEX Destruction. There isnt a second Material for Chunks

Hello there,
i have a problem. If i create a destructible mesh, there isn’t a second material slot for the broken chunks. I have only the first one.

I tried it with the + symbol for another material. Ok, i can input a second Material now, but it doesn’t work on the chunk… you cant see it.

Maybe anybody have an idea whats wrong here? In older Versions this worked fine… but now…

greetings :slight_smile:

No one? C’mon folks… Thats nasty ■■■■^^

Found this looking for the answer myself. The mesh has to be completely closed.

There are other posts too that explain this. Hope it helps.

Hey Dryfter, thank you :slight_smile: I’ll take a look and write an update, if I can solve it or not :wink:

oh hell yeah it workes… So I have to tell my 3D Artist, that they should take a lokk if they closed the meshes. Thanks a lot Dryfter for this amating hint!

I’ll copy and paste the answer from the other Post here for faster solution for other people :slight_smile:

" …When you make a destructible mesh you need to make sure that it’s a closed mesh. If not you will see issues like this.

The problem is a direct result of this because when the voronoi pattern is used to cut your mesh apart it has to be able to create faces where it cuts. If the mesh is not a closed mesh this is a direct result of that. "

i have a simular problem…my mesh is closed…it creates faces where the mesh is cut…but it only has the original material slot…and i don’t get another slot for the inner parts…so it just tiles the original material over and over on the cut faces and looks really bad…i tried to add another material but doesn’t work…any idea what is wrong?

I reworked my mesh, closed the whole mesh and deleted all N-Gons. After this I delete the mesh in Unreal Engine and imported it new. I had not used the reimport function, because I wont keep any failures on the binary level.

Then I created a new destructible Mesh and on the right sight in Destructible Settings under the area for Skeletal Mesh you have Materials. If you only have one there, just click on the plus and add a new one.

Another, much more performance-saving, way is to apply the Voronoi Fracture algorithm directly in the 3D program. This allows you to divide the mesh first and then optimize the pieces again.

(But be careful to not optimizing mesh before destruction, e.g. by deleting polygons! You need the closed mesh here also)

Then you no longer uses the destructible mesh function of UE4, but instead simply swaps the mesh with the help of a blueprint.

This does not take much longer in the “manufacturing” of the destructed mesh, but you have much more control over the mesh and can optimize it far better for a better performance.