UE 4.15 upgrade hangs on UnrealHeaderTool

Upgrading my project from 4.14.3 to 4.15, I get a warning about substance plugin required, but not available. Then I have a process called UnrealHeaderTool running at 100% CPU for hours now. The progress bar never moves. The only thing I can do is kill the UnrealHeaderTool program in task manager. Then UE4 never really starts.

Thanks for any help or suggestions.


Did oyu try to update substance? all plugins always need to be rebuild to new engine version

Yes, I did. I was able to load the new substance plugin to 4.15, but it didn’t change any behavior. I tried updating my version of the C++ battery tutorial and it did the same thing. It hung up on UnrealHeaderTool at 33% of “Generating Code” step.

Hello primaryKey,

I have a few questions to ask you about this issue:

  1. Are you using a source built editor or a binary one from the Epic Games Launcher?
  2. If you’re using a source built editor, are you sure it built successfully? The error message “Failed to initialize the engine” points towards problems with the editor rather than the project itself.
  3. Does this happen with any code projects that you create in 4.15 or only this converted one?
  4. Ever since you updated to the new substance version, are you still receiving the message about substance missing? You mentioned nothing changed so I wanted to make sure.


  1. binary editor from Epic Games Launcher
  2. this only happens with C++ projects. Blueprint projects convert successfully.
  3. I’m no longer receiving messages about substance missing.

When I attempted to convert another 4.14 project now, I got an error that enum must be of type uint8 only. I changed enums in all of my projects and have now successfully built the projects and completed the upgrades of them.

I can’t say why the HeaderTool hung repeatedly on them only when substance was out of date, but it runs perfectly now.

This issue can be marked solved.