Download

UE 4.15.1 + FMOD 1.09.03 + Oculus Audio SDK 1.1.3 = fail to build

Gear VR project fails to build when using UE 4.15.1 + FMOD 1.09.03 plugin + Oculus Audio SDK plugins 1.1.3

UE4 output log: http://pastebin.com/Fx06LZzW

I am also seeing this: http://pastebin.com/Encki7He (maybe not related to the failure to build, but really shouldn’t happen)

I am not sure what exactly causes this issue, so I posted on both FMOD and Oculus forums too and bug report is on AH: UE 4.15.1 + FMOD 1.09.03 + Oculus Audio SDK 1.1.3 = fail to build - UE4 AnswerHub

P.S. I suspect it’s not UE4 issue, but maybe someone had the same issue and they resolved it already.

I was getting errors similar to this. The editor would not package or launch anything with a c++ file for android using 4.15.

It turned out I needed to update CodeWorks to the latest version. I opted for 1r6 from nvidia, everything works now.

https://answers.unrealengine.com/questions/578929/launch-and-package-fail-for-c-android-projects-in.html

hope it helps.

I don’t use CodeWorks and I can easily package for Gear VR without FMOD. It’s the issue related specifically to FMOD plugin for UE 4.15.

Btw, what Clang version does 1r6 come with ?

C:
vpack\android-ndk-r12b oolchains\llvm\prebuilt\windows-x86_64\bin>clang.exe --version
Android clang version 3.8.256229 (based on LLVM 3.8.256229)
Target: x86_64-unknown-linux
Thread model: posix
InstalledDir: C:
vpack\android-ndk-r12b oolchains\llvm\prebuilt\windows-x86_64\bin

So, I tried updating Android Studio/SDK and got that android.bat file no longer in use error. Since there is no way to roll back, I decided to install Codeworks. Did that and UE4 doesn’t even let me build for Android now. In other words, now I am totally f$%ked, until Epic fixes UE4 to work with Android-25 SDK. Geez, what’s a week :mad:

After some black magic and dark rituals I managed to get Android environment set for API-24 and not API-25 (which is forced upon us by Google in recent versions of Android Studio) and got most recent NDK too. So far so good - building for Gear VR is happening.

Apparently 3.6 clang is too old for FMOD (but not for UE4). Clang 3.8 seems to be what FMOD 1.09.03 needs, at minimum.