UE 4.15.1 + FMOD 1.09.03 + Oculus Audio SDK 1.1.3 = fail to build

Gear VR project fails to build when using UE 4.15.1 + FMOD 1.09.03 plugin + Oculus Audio SDK plugins 1.1.3

UE4 output log: http://pastebin.com/Fx06LZzW

I am also seeing this: http://pastebin.com/Encki7He (maybe not related to the failure to build, but really shouldn’t happen)

Hello motorsep,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any settings/blueprints that may be involved with this issue?
  4. Does this issue still occur without using FMOD?

I noticed that you have already created a post with the support with FMOD (link provided below). If this issue does not reproduce without FMOD I would suggest continuing with that post for further assistance as we do not provide support for unofficial plugins.

Link: UE 4.15.1 + FMOD 1.09.03 + Oculus Audio SDK 1.1.3 = fail to build - Unreal Engine - FMOD Forums

Hi Rudy,

Before going any further, here is what Oculus had to say about the issue:

"With regard to this specific report, we broke backward compatibility with FMOD with 1.1.3, you say you are on FMOD 1.9 which is compatible but my guess is your IE4 integration isn’t updated and 1.8.x which won’t load our plugin. "

I will try testing it with clean project, but it just sounds like UE4 FMOD related code (for Oculus plugins) is outdated.

I can’t build project without FMOD because I’d have to go over my BPs and remove FMOD BP nodes. What I could also try is building with FMOD, but without Oculus plugins (but if FMOD has some specific code that relies on compatibility with Audio SDK 1.1.3 then it will fail again anyway).

Alright, here is what happened:

  1. Yes.
  2. I created clean project, made sure it builds for Gear VR without FMOD. Then added FMOD 1.09.03 plugin (without Oculus Audio SDK plugins), added FMOD Audio event to the level (as actor, without BP and as BP actor with sounds starting on Event Begin Play), tried packaging and got the same errors when trying to package.
  3. It’s definitely not related to BP or settings. All I did was I made BP FPS Template project (mobile, no starter content), made it build and run for Gear VR, added FMOD and that was it. Here is a quick video of my settings: 2017 03 22 21 52 50 - YouTube
  4. Nope, it only occurs with FMOD. It’s 100% related to UE 4.15.x and new FMOD 1.09.03 for UE 4.15 (I’ve had no issues with UE 4.14.3)

I also updated Android SDK and NDK to the current ones. Tried Android API 21 instead of my default 19 and it’s still the same issue.

Really hoping it will get resolved in 4.15.2 or .3

After some black magic and dark rituals I managed to get Android environment set for API-24 and not API-25 (which is forced upon us by Google in recent versions of Android Studio and UE4 doesn’t work with API-25 at all as it kills android.bat) and got most recent NDK too. So far so good - building for Gear VR is happening (I can’t confirm right now if FMOD + Oculus Audio SDK build and run fine; will confirm on Sunday).

Apparently 3.6 clang is too old for FMOD (but not for UE4). Clang 3.8 seems to be what FMOD 1.09.03 needs, at minimum.

Thank you for the updated information. Please be sure to update the thread when you have more information on weather or not your issue still occurs after making the changes mentioned in your last post.

Alright, 4.15.1 + FMOD 1.09.03 + Oculus Audio SDK 1.1.3 plugins seems to build and run (no sound in PIE, but that’s probably between FMOD and Oculus).

Clang 3.6 was the issue.

I am happy that you were able to find a solution to your issue. I will be marking your last post as the answer. If the issue returns, feel free to reopen this issue with any additional information you may have.

Make it a great day