UE 4.15.0 Crash on Build Mac

Hi Steve, rajibkumar,
I finally got rid of the crash - I found interesting things about Material blueprints as well.

I went on all the material and did some stuff (Scaled down texture - not sure if it affected my crash at all).

I think that the main part which did the trick (sadly I can’t confirm because I changed a lot of stuff) was switching between “Surface ForwardShading” to Surface “TransluciencyVolume” previously I though that I must use forward shading for SSR apparently it works on a Translucent as well :).

Then I transferred it to mac and it built successfully,
However I didn’t see the water at all :slight_smile:
Going in to the material editor: [SM5] You are using 17 texture samplers 16 is max…
Opening the same just ported in Windows 15/16 :slight_smile:

Then I found the same texture was sampled 2 times in Mac was counted as 2 texture samples :(…

From what I have a feeling that Material Blueprints are lack of trivial Optimizations (Off trivial in terms well maintained compilers :wink: ) :open_mouth: is that so ?

So far so Good I have everything up and working for now.

But it would be great to know why Mac branch failed to build - so I can learn what not to do on it.

Best Week Guys!
Roma.

Well not that fast :frowning:

After I wrote the last message I got my crash again without any changes…

But I surely was able to build it before I wrote the comment…

I think something is broken with this blueprint…

Same thing on Windows tells 15/16 texture samples and on Mac it says 16/16…

In Any case I failed to fix it :frowning:

I have been trying to build ios app. Worked mac but frustrated as it’ hardware config is low, kept crashing. Now trying to work on windows and trying to remote compile on mac. DId you try with high config Mac, better graphics card?

HI rajibkumar ,

Unfortunately it is the only mac I have :frowning:

Hey Steve,
it’s being a week, I wonder if you had a look on it recently ?

Sorry, for the delay but I finally had a chance to look at this and here are my results:

I was able to add the WaterPlanes Material to a blank project, apply to a large static mesh “plane” (stretched out box) and package if for distribution for Mac. This opened and worked as expected.

A couple thoughts, I added the 4.15 version to a 4.15 project rather than upgrading from a 4.14 project with this asset to 4.15. While this may work in Windows, Macs use different rendering methods that may not be compatible between versions. Hence, I recommend deleting your current WaterPlanes in your 4.15 project, then adding them back directly from the Launcher site.

Secondly, unless I missed it skimming back throught this post, I do not believe you have said what platform you are publishing to and specified what packaging settings you are using. In my test, I packaged for Mac, distribution, full rebuild, did not use Pak file or generate chunks.

Please try the troubleshooting steps above, in a blank project first, then in your project and let me know if the crash persists.

Hi ColdSteel48,

Since we have not heard back from you in a while, we are marking this post “resolved” for tracking purposes. However, if you are still experiencing a crash with the Water Plane asset please respond with the requested information above and we will continue to investigate.

Note: you may want to try opening the the Water Plane asset in a blank UE4.15 project, see if that builds in a test package and, if so, migrate that assent to your current project replacing the current Water Plane asset.

Thanks,

Steve H.

Hi Steve,
I was not able to go over it yet,
I am working on AI in present time and almost have no resources for a water plane.

I already tried opening it in a blank project and it worked fine.

Remigrating is a bit more complicated (Since I changed things and I want those things to remain) that means I will have to kill a lot of time remaking it to be the same.

I suppose it is fine to mark it as resolved.
Thanks you for the help :slight_smile:
B.R.
Roma.