Download

UE 4.14 is broken! Extremly bad performance after update - HELP!

Hello and “happy” new year.

Not for me right now… I’m having massive problems with UE 4.14, the GPU time is for some reason extremly high.
The GPU time exploded for unknown reason. I haven’t changed anything on the game compared to UE 4.13 version. Even after optimizing Textures and Meshes with new LOD the performance is absolutly broken.

The game on maximum settings:
5475b2240f0b60dd7da480510d7dca027ced27cb.jpeg

Same szene on absolute minimum (no shadows, texture size and resolution scale and the absolute minimum):
5aa111c389fa0e52d96baf1150bec41572749bf2.jpeg

Changing the graphical settings has no effect on the performance. Before the update this scene would run with ~90FPS on maximum settings, now I’m stuck at around 30 FPS.
In the Editor the FPS are still ok:

The GPU is limiting for some reason. The strange thing is that on some maps the performance is still ok (I havend worked on/saved those maps in UE 4.14). And If this isn’t enough the 30FPS I’m getting right now are feeling like 90 FPS on one map, on the other it’s feeling like real 30 FPS.

I can’t go back to 4.13 because 1 month of work would be lost and I’m now in a big trouble, I need to release this game in Q1 and I don’t know what to do.
Here is my System: DxDiag.txt (94.9 KB)

Does anyone have an Idea how to fix this? Thank you very much!

I’ve been experiencing the same issue, except in a much, MUCH worse way. The game I’m working on has gone from ~25 FPS on max settings to less than 1 FPS on anything better than low settings after the 4.14.1/4.14.2 update.

The only thing I’ve found that works is setting the preshadows off (“r.shadows.preshadows 0” in the console), which returns the performance back to about 30-35 FPS. Dumping the shadows (“r.dumpshadows” in console) doesn’t show anything out of the ordinary and disabling shadows manually on ALL the actors in the world doesn’t solve the issue, either. Disabling the sun / moon light sources only provides a mild (1-3 FPS) improvement in performance when preshadows are re-enabled, so that’s not much help.

You’ll probably have to use the profiling tools: Performance and Profiling | Unreal Engine Documentation