[UE 4.12.0] Github Promoted branch - Unreal Engine task: CPU usage at least 50%

Everything is in the title…
I always have 2 UE installations on my machine:

  1. The latest UE4 installed from launcher (for instance 4.11.1)
  2. The promoted branch from GitHub (for instance 4.12.0)

For the 4.12.0, builded with VS 2015 Update 2, the Unreal Engine task is consuming 50% (on AVG) of all 4 cores.
No matter starting the editor or waiting from Project Browser (even minimized), the issue appears as soon as “Unreal Engine” Task is started with the splash screen.

The issue doesn’t exist with the official 4.11.1 release installed from Launcher, only the one builded from sources.
System: AMD X4, windows 10, VS 2015.

Latest promoted build is 4.13.0. This high CPU usage is still present.
Can you reproduce this?

Hi Tensa_Zangetsu,

I tried building the Engine from the Promoted branch of the Engine today, but ran into some build errors. I will give it another try as soon as a new build is available (hopefully tomorrow) to see if I see the same results that you are describing.

Please keep in mind that the Promoted branch of the Engine does not receive a lot of optimization, so this may simply be a case where the Engine is not fully optimized. I will try to verify if that is the case when I am able to build the Engine from the Promoted branch.

I have some issue with 4.12 and master branch (UE 4.13). Engine, that built from sources from that branched use about 2 cores and my 4 core CPU (i7).

Any news on this?


Any news on this?

Still no news ((( ?

Hi Tensa_Zangetsu,

I had a to dig into this some more today. I downloaded and built both Promoted and Master branches of the Engine and compared CPU usage with the binary version 4.11.2 installed through the Launcher. For both the Promoted and Master builds of the Engine, when I launched for the first time I saw CPU usage around 80%-100% as shaders were built for the first time. Once this was completed however, my CPU usage dropped to 10%-20%, which were the same levels I saw with 4.11.2. I also tried opening a blank Blueprint project in each version of the Engine and did not see any appreciable increase in CPU usage.

Do you see high levels of CPU usage even after the shaders finish compiling the first time you open a newly built Engine? Are you able to tell what percentage of the CPU is being utilized by the UE4Editor.exe process?


Just to make sure I understand your question correctly, are you saying that when you are running the Editor it only uses 2 of your 4 cores?

Solved by (yeah, I’m his fan and follower :slight_smile: ) in .

Now in UE 4.13 (UE master branch) this bug is resolved.

I’ve just pull the latest build from promoted and I confirm the issue has been solved.

Yeap confirmed to be fixed :slight_smile: