UE 4.12.0 crashes. Add a FormatText node to arg pin by "{}"

Sorry, I’m not good at English.

  1. Open level blueprint.
  2. Create a FormatText node.
  3. Write “{}”.
  4. Compile level Blueprint.
  5. UE4.12.0 crashes.

For example,


However, UE4 doesn’t crash when use a Make Literal Text node as shown in graph2.png.

Hello unwitherer,

Thank you for your report, but I have not been able to reproduce the crash. These are the steps I followed, can you confirm them?

  1. Create a new First Person Blueprint project in 4.12.0 (2992821)
  2. Open Level Blueprint
  3. Add the nodes: Event Begin Play, FormatText, Print Text (connect them)
  4. In the Format field, enter: {} is unsuccess
  5. Compile the Level Blueprint
  6. Click Play

This successfully plays the level and prints “is unsuccess”

Please let me know if there are other required steps.

Thank you.

Hello Stephen Ellis,

Thank you for answering.

In the beginning, I confirmed the version. It is a 4.12.0-2992821+++UE4+Release-4.12.

Next, I tried your steps so carefully, and unsuccessed compiling(errorlog2.png) only when I used Enter Key to finish input, but successed compiling when I didn’t use Enter Key to finish input, for example I clicked on graph of outer node.

Please confirm more detail steps just in case.

  1. Create a new blank blueprint project without starter content in version 4.12.0.
    (For your information, my project location is C:\Users****\Documents\Unreal Projects\MyProject2)

  2. Open Level Blueprint

  3. Remove nodes: EventBeginPlay, EventTick

  4. Add nodes: FormatText

  5. In the Format field, enter: {} (use EnterKey to finish input)



  1. Compile Level Blueprint
  2. Crash before finish compiling

I tried your steps and the above steps in two pc environment, and I can reproduce this problem.

Thank you!

Thank you for the detailed information, however I still do not reproduce the crash, even when I follow all your steps and press the Enter key. I would like to consider other options that may be causing this crash.

I have searched our database for your crash, and I have located your submission (for my reference, #5084851). I see that your system language is set to Japanese, we will investigate if that may have an influence.

Are you using an English keyboard, or something else for translation?

Other users are also experiencing this crash, and we are tracking this bug as UE-31442, but we do not have reproduction steps yet.

Thank you!

Actually, I have identified that every user who crashes is using Windows 10. (I am testing on Windows 7). We will test this.

Are you using an English keyboard, or something else for translation?

I’m using the following pc environment.

OS: Windows10 Pro 64bit(Japanese)
Keyboard: REALFORCE108UBK(JIS keyboard)
Input Method: Japanese(Microsoft IME)

I’m using the REALFORCE108UBK. It’s not US keyboard but JIS keyboard. JIS keyboard is different from key position of “}” and “{”, but I don’t seem like that key array cause the problem.

I’m not good at English, so please look at langconfig1.png, langconfig2.png and langconfig3.png.
I have tried to add a English language pack to OS(langconfig1.png), and added an input method “US” and “Japanese”(langconfig2.png). I retried the above steps(langconfig3.png), and I encounted the problem only when I used input method: Japanese(Microsoft IME).


I don’t know any more. Maybe It is specific problem of Japanese(Language pack).
I will use English(Language pack) to work around a error.
I hope you will find the corrections helpful.

Thank you!

Thank you again for the additional information. When we tested with Windows 10 (English), we did not experience the crash. However, we will continue to test with Japanese language settings.

Hello unwitherer,

I was able to reproduce this crash in Windows 10, but only with the Microsoft Japanese IME. Using the Google Japanese IME I was unable to reproduce this crash.

Not sure if you’ve tried it, but a lot of the support team in Japan thinks that the Google Japanese IME gives better suggestions. Also there is a slowdown in refreshing the blueprints window if using the Microsoft Japanese IME (we have to register each input box with the IME by calling it’s API, but the Microsoft IME is slower to return from that call than the Google IME).

We’ll try to fix this crash in relation to the Microsoft IME, but in the meantime I recommend, for a variety of reasons, the Google IME if you haven’t tried it.

Thanks for the report!

Out of curiosity, does it still crash when putting something within the { and }, eg {0} rather than {} (the latter isn’t really a valid format marker, so might be causing a buffer overflow when extracting the format arguments for the Format Text node).