UE 4.11 - Show Mouse Cursor breaks mouse coords

REPRO:

UE4.10 (working)

  1. Open ShowMouseCursor_4.10 project in zip file

https://dl.dropboxusercontent.com/u/15053325/ShowMouseCursor.zip

  1. Press PLAY, then press any mouse button and move the mouse around

result:

(a) cursor is visible, as expected

(b) mouse coordinates are displayed, as expected

.

.

.

**UE4.11 (broken)
**

  1. Open ShowMouseCursor_4.10 in UE4.11

  2. Press PLAY, then press any mouse button and move the mouse around

result:

(a) cursor is visible, as expected

(b) mouse coordinates are initially visible,
but as soon as you press any mouse button the mouse coordinates stop being received.

Any blueprint that depends on [Show Mouse Cursor], [GetX] or [GetY] mouse coordinates is broken.

If you uncheck [ ]Show Mouse Cursor (in the level blueprint) then mouse coordinates are received but you’ll then have to implement your own custom mouse cursor.

Hello ash22,

First off I would like to say thank you for your effort in filling out a detailed report. With that being said this is a known issue (UE-28811) and it has been submitted to the developers for further consideration. I have provided a link to the original post. Please feel free to visit that post for future updates. I hope that this information helps.

Link: Show mouse cursor disables mouse events - Programming & Scripting - Unreal Engine Forums

Make it a great day

Ok, thanks Rudy.
That’s weird (UE-28811) because I’ve been using ShowMouseCursor, GetX, and GetY quiute extensively since 4.6 and never had any problem until I opened my project in 4.11 this morning.

Its a 4.11 bug. Mouse input only works correctly in blueprints if you have the mouse cursor disabled now. Input Axis mouse bindings don’t function either while the cursor is shown.

@Nordrak,

Just wanted to say, awesome work. I converted my card game from 4.10.4 to 4.11 and all of a sudden I need to click a random amount of times in my cards for the click code to run at all. You were of great help to know what my issue was and how to go around it, at least for now. So thanks. Hope they get this fixed in 11.1