UE 4.10: Matinee videos are dark

I had a bunch of cinematic sequences set up in UE 4.9. When I re-recorded them in UE4.10 and imported them into Premiere, all of them were extremely dark. Furthermore, I found that putting them in Premiere in a track in front of another track causes both tracks to render, with the track recorded in UE4.10 seeming to “ghost” in front of the old one.

So that tells me that when it records the AVI, it seems to be adding some kind of transparency, which seems to be what’s causing the darkening.

If I re-record the AVIs as WMV files using Windows Movie Maker, they then import into Premiere just fine.

I’m recording them as AVIs with no compression.

Hey Mothership.Entertainment,

I am in the process of running some tests and we have definitely made some changes to the workflow I am used to when rendering out a captured Matinee cinematic as an AVI. Would you provide me with some simple reproducible steps to follow in order to see what you are reporting, on my end?

Some screenshots of the settings you are using for the ‘Movie’ dialog window in matinee, as well as the ‘Details’ panel of the matinee actor within the level will help me greatly. If you have questions please let me know.

Thank you,

Andrew Hurley

Hi Andrew – Yes, of course.

I used these settings:

Interestingly, videos seem to play fine in Windows Media Player; it’s specifically Premiere that seems to be the problem.

I can also get you some of the original uncompressed AVIs that I’m seeing the issue with if that would be helpful to you at all (though they are 5+ GB each so I’d need a big DropBox folder or something to put them in).

To clarify, both the AVI and WMV file
type look fine when played on the
Windows Media Player, but when you
bring the newly created (and
uncompressed) AVI into Premier it
appears darker?

Yes, that’s correct. I recorded 3 separate AVIs this weekend using those settings, and they all had this problem and all had to be re-compressed as WMV files before they would appear properly in Premiere. Let me get you some screenshots …

Thank you for the screenshots. I actually stumbled across another issue related to a freeze in Matinee when recording a movie, using the default output directory. Just in case your editor freezes and this occurs to you, the current workaround for this is to change the directory to something shorter, like your desktop for example.

To clarify, both the AVI and WMV file type look fine when played on the Windows Media Player, but when you bring the newly created (and uncompressed) AVI into Premier it appears darker?

I was able to get an AVI exported and did not see any darkening between the editor playback, and the rendered out movie. Perhaps I am doing something differently?

Cheers,

Andrew Hurley

OK, here are the original AVI and then the WMV version of that same file, both in the same video track in Premiere, and the AVI is about 50% the brightness of the WMV.

The AVI:

The WMV:

Again, I’d be happy to send you the AVIs if you’d like, though they’re super-huge …

Sure, I’d been having issues with the compression in Matinee, so I’d turned it off, but I’ll turn it on and give it a shot …

I am wondering if the compression could have something to do with this as well. Thank you for the screenshots, they are quite helpful!

Would you mind testing to see if compressing your AVI has an effect on the brightness of your video when viewed in Premiere?

Yes, it works fine if I use compression. Here are the settings I used this time:

I’d avoided using compression because I was having some issues with recording cinematics, but that was likely due to my old nVidia GTX 770 video card, which was hard crashing when recording cinematics and which I’ve now replaced with a 980.

I went ahead and entered a bug report (UE-23651) for this issue. It seems the uncompressed AVI movie file is exported with an incorrect alpha channel (see image).

Thanks for taking the time to provide me with the requested information, and for posting this on the AnswerHub. Once the bug is fixed it will be integrated in an upcoming release.

Cheers,

Andrew Hurley

Is there anything new about it?

Hi Carlos_SM,

UE-23651 is fixed for 4.11 and should be live in the 4.11 Preview builds.

-Matt W.

I’m using 4.15 and have the same problem, videos look darker and not the same tone as seen on the sequencer
I’ve tried exporting uncompressed video and png sequence, same problem

I’m using 4.15 and have the same problem, videos look darker and not the same tone as seen on the sequencer I’ve tried exporting uncompressed video and png sequence, same problem

Hi KidLoko,

Please report this in a new thread. This is a very old issue and your problem is probably occurring for different reasons.

-Matt W.

I’ll do, thank you!