UE 4.10 and Epic Game Launcher fail to install prerequisites with Error Code R-1603


I am logged into Administrator account (easy, it's just me on this machine).

EpicGamesLauncher and UnrealEngineLauncher are set to run as Admin

As far as I can tell WIndows 10 Pro x64, Direct X, and VS 2015 redist.  is up to date

The Launcher pops the error after downloading the same 35.7 mb update each time (glad my connection is not metered). Clicking Okay opens Launcher, where 4.10 is downloaded (button says “Resume”), but refuses to install after verifying with same error code. All previous versions launch correctly.

Logs and Dxdiag attached. Hope it helps narrow down the issue.
link text

link text

Fix as mentioned in accepted answer. Bored roommates are exceptionally handy.

Tl;dr If you have any way to get the newest version installed on any computer, do so, then copy the
C:\ProgramData\Epic\ and actual installed Epic Games\Launcher folders to where they should be installed on the computer you want them on (I keep mine on a separate drive from C:).
Open the \Launcher\Engine\Binaries\Win**\ folder and run the UnrealEngineLauncher.exe as admin, this bypasses something important to get you to the log in. Once logged in, it’ll ask if you want to update shortcuts. Do so. Done, and the launcher is updated. Oh, and don’t forget you may have to do the install (on the other computer to copy from) through elevated command prompt, because permissions are done in some way that makes no sense.

on a similar thread Stephen Ellis responded:

There is an issue however where on
Windows 7 and 8, it requires previous
Windows updates to be installed to run
correctly, and will fail without them.
this was helpful to me, but it took me nearly a full day of searching to find this information. maybe Epic could specify in the error message about this windows 7 & 8 issue?

Hello Sikotik,

I’m sorry to hear that you are having trouble. The logs that you provided are the standard ones. Could you please follow the steps here and generate the debug logs?

Strange, that was the procedure I followed to generate the logs. I can do it again, I suppose, but those were the only logs created.

Hi Sikotik,

The error message you are getting is generally due to a permissions error. Even though you are the only person on the system, could you please try right-clicking on the Epic Launcher icon and going to “Run As Administrator”? Please reply back with the results.

Hi Sikotik13,

We haven’t heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you’re still experiencing this issue, please try the suggestion that I mentioned above then post back here with the requested info.

Sorry, I got busy with class. I would have attempted your fix, if it wasn’t listed as point number 2 of my post detailing the issue.

I have since manually deleted the launcher. This, of course, fixed nothing, but I can’t reinstall it for the same prerequisite error, so I guess I’m just SOL on this issue. I also tried everything detailed in numerous posts regarding this and similar issues/error codes (Un/install VS 2015 Redsits, manually run prereq installers as admin, etc.). All Unreal Editor versions (Including the 4.10 version the launcher could never install) open and run just fine. Given that it’s the sole thing (including all of Epic’s other Unreal related things) that cannot figure out how to install/update itself (or just run correctly or at all, now), I won’t bother with a fresh Windows install that may or may not fix what appears to be, essentially, a poorly done launcher.

This may still be considered closed, as the launcher was my issue, and I have removed it, but I consider this anything but solved.

First off the error lies with outdated shortcuts, secondly if you have an updated unreal launcher you can run that sign in and be able to update said shortcuts. Luckily for Sikotik here, I happen to live in the same location and have a working version, which was a pain to install as the permissions for the installer are incorrect and only installs if you use the command prompt as administrator(might want to fix that). Basically he copied my files to his folder ran the unreal launcher which fixed the prereq error R-1603. If you can figure out some work around to that it will work, secondly not sure if this would work but after installing the Epic Launcher, go run the Unreal Launcher(newest version), which should install when the Epic Launcher. Sign in and update your shortcuts. That was all it took to get him past this error.


We have recently updated the launcher to address some of the prerequisite issues. Please see the accepted answer to this post for the steps to follow.

If this does not resolve the issue and you would like to continue with this issue, please reply back.