Download

UE 4.10.2 downloading getting stuck at 40% ......waited for 2 days now and still the same

I was updating 4.10.1 to 4.10.2 but it got stuck when 634 MB was left but then I thought I should uninstall completely so I did even I uninstalled the launcher to get latest one and reinstalled launcher and kept to download UE 4.10.2 then again it got stuck at 40% and now it’s two days it’s still 40% I don’t know what’s the problem but if anyone have solution please let me know.

Is your internet connection okay?

If so, try cleaning out the registry and other junk by using CCleaner. (Or something like it.)

After that I would recommend reinstalling the launcher and trying again.

P.S. If none of that works, try a good old fashion Virus scan. You never know.

My internet connection is totally fine but right now I am going to follow other steps that you mentioned …thank you for help

I was going to mention CCLeaner registry cleaning also.
I just did a fresh/first ever install last night no problems.

Is there a Unreal Temp/Download folder to clean out? I ask because hopefully someone more familiar with UE Launcher could shed some light on the subject. I am brad new to it.

How long was it “stuck” for? It’s possible that it was just downloading a large chunk file that takes a few minutes.

If you still think there’s an issue, please use the following guide to get your debug logs, and creating a post on the UE4 Answerhub for further assistance. https://wiki.unrealengine.com/Troubleshooting_Launcher_Problems#None_of_the_Above_Helped_-_Getting_Debug_Logs

It was stuck for 2 days (4th day now) man I did ccleaner + registry cleaner…and I did post on answer hub but no one replies and btw my internet speed is fast enough to download HD videos on youtube and till now all previous engine I did download from this internet so after that I read some same complain that other users got and then there were some answers regarding uninstalling the visual studio and also prerequisites (previous versions) so I did everything and nothing worked…but today I just formatted my PC (C drive) and and now kept it for download will update tomorrow what happens.

Here is the answer hub link: https://answers.unrealengine.com/questions/364958/ue-4102-downloading-getting-stuck-at-40-waited-for.html

Thank everyone of you for reply.

this is fixed in the hub link btw

https://answers.unrealengine.com/que…aited-for.html