UE 4.10.2 downloading getting stuck at 40% ......waited for 2 days now and still the same

I was updating 4.10.1 to 4.10.2 but it got stuck when 634 MB was left but then I thought I should uninstall completely so I did even I uninstalled the launcher to get latest one and reinstalled launcher and kept to download UE 4.10.2 then again it got stuck at 40% and now it’s two days it’s still 40% I don’t know what’s the problem but if anyone have solution please let me know.

Man this is serious problem please help I want to download as soon as possible

Would you post the logs if you know how to find them? This sounds like an error I’ve seen where all of the .png files break the download.

link text

Hi delvegamer,

I’m sorry to hear that you are having trouble. Could you please attach your DxDiag and debug logs to your ticket? Use the process here. The debug logs will have more information than the standard ones.

link text

Hello Sir…
I have compressed(.Zip file) the debug file cause it’s size was 9 MB…

Thank you

link text

Here is the DXdiag file

Hello again,

Please make sure that you disable any antivirus or network monitoring (firewall) software that you have running. Is your system connected directly to your WAN via modem or does it pass through a router first? If you are going through a router, is it possible to connect directly and bypass the router?

I tried without antivirus but still problem is there and btw I am using (Dongal internet 3.1 Mbps…I am getting download speed around 180 kbps when I download) but I wanted to ask is it important to use Ipv6 instead Ipv4 ??? cause my UE4.10,2 download issue is still there.

I also tried Github download but even after 100% download and building all files of UE4 in VS2015 community… its says error some “.h” related and there is no UE4editor file in win64 folder (VStudio 2015 community) was keep showing this error that no “cache file” etc …there were 7 errors and btw I downloaded twice but still the same…now again I am still trying to download it from Epic launcher. but same .png error in log file and download getting stuck…I can’t tell you how happy I am.

Hello again,

This issue is sometimes caused by your router struggling with the number of connections due to too many downloads happening simultaneously. To work around this issue, try the following steps. As a note, this workaround may result in lower download speeds, but should allow your download to complete eventually.

-Navigate to Computer> Local Disc (C:)> Users> [your username]> AppData> Local> EpicGamesLauncher> Saved> Config> Windows.
(Note: The AppData folder is hidden by default. If you are unable to see it, you will need to change your settings so that you can view hidden folders.)

-Open the file named Engine.

-Add the following lines to the end of the file:

-Save the file.

-Retry the download.

If you still have trouble, you can try setting ChunkDownloads, which represents the number of downloads that will run simultaneously, to 2 or 1.


Thank you for solution but I actually downloaded the Source code from GITHUB and compiled it in VStudio 2013 and it worked…but in 2015 it was giving an error anyways I got my UE4.10.2…everything is fine now…and btw the solution you are talking about (adding [Portal.BuildPatch] ChunkDownloads=3) I tried those things before but those things were not working at all and yes I did reduced number as well…but anyways VStudio 2013 helped me. (VStudio 2015 seems very strict) …

(btw this will help someone …if any user gets the same problem and trying to compile source code downloaded as ZIP file of UE 4.10.2, won’t compile in VStudio 2013 or any other version of VStudio if he doesn’t have that hidden folder of GIthub which you get when you download SourceCode through Github desktop app, it contains some important files…so I would recommend to download with Github app not the ZIP files)

Thank you